Unable to update AV after program update 8.4.0.5068

Win 7 x64 - CIS 8.4.0.5068

Program just updated and gave me an out of date ! red warning for my virus database. I hit “Fix It”, and everything runs fine except “Install Signatures” has a red X and states error. I have restarted and tried everything except uninstalling and reinstalling. I don’t want your product if I have to uninstall and reinstall every time you update it.

It states…
“Status: Class not registered”

I can not update signatures either. Updated the version last night, Windows 10 x64.
I see the same error when trying to run Update today.
Are the servers down?

I uninstalled and reinstalled CIS and made sure the virus database was up to date before upgrading the program. After wasting hours re-configuring (not all settings are saved), and doing restarts after updates…

I got to 8.4.0.5068 without the problem. We will see if it recurs when the database expires and must be updated.

I do not appreciate this unprofessional release of an update.

Well, if you wanna use CIS, better you get used to this kind of issues, especially when you face a major update (for example from 8.X to 8.Y)
I’m already getting headache thinking about updating from CIS 8 to CIS 10… ;D

Hi Jon79,
Only positive thinking will net positive results. :wink:

Kind regards.