Unable to uninstall Comodo Firewall

Hello everyone!,
I wanted to uninstall Comodo Firewall from my Windows 10 (64-bit operating system); however, whenever I go to Control Panel->Programs->Uninstall, I receive this message:
“The feature you are trying to use is on a network resource that is unavailable. Click OK to try again, or enter an alternative path to a folder contianing the installation package “cis_setup_x64.msi” in the box below.”
Right after I close the window, immediately, another window appears, stating the follow, “The installation source for this product is not available. Verify that the source exists and that you can access it.”
Does anyone have any suggestions? I would greatly appreciate anyone for assistance with this uninstall issue. Thank you very much!

I think what happened was you installed CFW using the msi installer instead of the package installer and you deleted the msi file when you where done hence it is looking for it when you go to uninstall. You can get the offline CIS installer from here and you should be able to run it which will give you the option to uninstall.

Hello futuretech,
Thank you for your help! I downloaded the link you gave me, and it comes up as the COMODO Internet Security Premium 10 Upgrade. It does not give me the option to uninstall. I am not sure what to do at this point. Do you have any suggestions? I hope to hear back from you soon! Thank you!

Then you should use 7zip to open the installer as an archive then navigate to cis\download\installs\xml_binaries\cis and extract the cis_setup_x64.msi file.

Hello futuretech,
I tried to archive the file; however, the file I downloaded from your link is just the installer.exe. When I archive the file, I am unable to find the other files. Do you have any suggestions? Thank you for your help!

Hello futuretech,
An update. I was able to follow your directions, and I found the file. However, I was also able to locate the file in my C Drive under the following location:
This PC>Windows (C:)>ProgramData>Comodo>Installer>cis_setup_x64.msi
I tried to re-route the path during the uninstall process; however, I am still getting the same error message. In addition, did you want me to copy and paste the file you suggested into the location I typed above, or do something else? I was not sure what you wanted me to do once you wanted me to extract the file.

I also should note that my Windows 10 computer was the upgrade (for free) during the phase where you can upgrade from Windows 7/8/8.1 to 10. My PC was initially Windows 8 (but then automatically updated to 8.1), then a Windows 8.1 (if that makes any difference).

Do you have any other suggestions? Thank you for all of your help so far!

Just run the .msi installer now that you have it and it should give you an option to remove.

Hello futuretech,
I tried that, and it is only giving me the option to install. Even when I tried that, a message appears, stating that I have to uninstall the older version of COMODO firewall before I can install the new version. If you have any other suggestions or help with this issue, I would greatly appreciate it. Thank you!

You should try doing the upgrade that you were asked when you ran the offline installer .exe file and then when that is complete the you should be able to uninstall from programs & features.

I did, and I received the same message, stating that I should uninstall the older version before I reinstall the update. However, I will update this post once I figure this out. If you have any other suggestions, please let me know. Thank you very much for all of your help!

Try using this removal tool.