Unable to set PDF plugin to "click-to-play"

I have the most recent version of IceDragon installed and my OS is Windows XP SP3

I set my PDF plugin to “ask to activate”, but when I open a link on a webpage that requires the use of the PDF player it still just opens the PDF player automatically.

Hi psylock,
I don’t use a PDF plugin, but I’m hoping I can still help you out. If you have your menu bar displayed, go to Tools/Options/Applications. If no menu bar displayed, then click on the IceDragon button, then Options, then Applications & scroll down until you get to Portable Document Format (PDF). It is probably set to use your PDF plugin. Click on it and use the down arrow to select ‘Always ask’. Then click ‘Ok’ to exit out of Options. The next time you click on a pdf file, a popup displays so you can select your PDF viewer if it’s not already selected and then make sure there is no checkmark in the box that says ‘Do this automatically for files like this from now on.’ Then click ‘Ok’ to save your changes.

I have my PDF option set to ‘Always ask’, but I don’t use a PDF plugin, just a PDF viewer.

Hope that helps,

I meant PDF reader not PDF player, I tried what you said and it does work. But I have a question. Before making the changes it was set to “Preview in IceDragon”. Is there a way to set the PDF reader settings so that it behaves the way that the flash player behaves when it is set to “ask to activate”? With the flash player plugin anything that requires the flash is grayed out and has a link that says “activate adobe flash” and when you click the link it activates the flash plugin. Is there a way to make the PDF reader plugin behave this way as well, where it is just grayed out and you have to press a link to activate the plugin instead of setting it to open the actual PDF reader application?

I just solved my own problem with your help gs22. In addition to Preview in IceDragon and Always Ask there is another option, Use PDF Plugin for Firefox and Chrome. I selected the Use PDF Plugin for Firefox and Chrome option and now I get the grayed out screen with the link to Activate PDF Plugin. Thank you for your help gs22.

Thanks for your comments. Sorry I wasn’t able to reply more quickly and offer more help. I’ve been away from the computer for most of the day.

Before making the changes it was set to "Preview in IceDragon".

Mine was the same way. It appears the default setting is ‘Preview in IceDragon’. I wasn’t sure if your PDF plugin would change it from the default setting.

Thanks for posting how you solved it. Others that use the PDF plugin may be interested in how you have yours setup. Great to hear that you got it working the way you wanted. That is always a good feeling. :slight_smile: :slight_smile: