Unable to run programs after Comodo updated today to Version 3.8.65951.477

I’m running Vista 64 bit Home Professional Service Pack 1, logged in as administrator and UAC is disabled

I haven’t been on my laptop for a couple weeks, and I’m running the free Comodo suite on it. I turned on the computer and it searched for (but didn’t find) a Windows update as well as performing a Comodo update. I noticed the comodo application agent had a big red X beside it, so I searched and found nothing recent to fix it. By the time all the updates had finished and I restarted my computer, I didn’t know what was really going on. Upon rebooting, I found that I could not launch any of my desktop or taskbar icons. I did a system restore to a point prior to the windows and comodo upgrades and my computer was working normally again. I tried uninstalling and reinstalling comodo a couple of times, as the full version and just the firewall and both times I had the same original problem, telling me it’s a comodo problem, not a windows problem.

The sequence of events was:

-Comodo downloaded/updated virus profiles
-I noticed the big red X by the Agent in the Summary page
-a suggestion I found was to turn Comodo off for a few seconds then back on- didn’t work
-a second suggestion was to re-install Comodo- I did this and upon completion, none of my programs would run
-system restore to point prior to reinstallation- programs worked again

  • tried it a second time- same thing
    -tried it a third time, this time just installing the firewall- same thing

I see the release notes for this latest version was supposed to fix this sort of problem, but where I didn’t have it before (unsure of the version i just updated from), I have it now. Any input would be appreciated. I don’t like my computer to be without a firewall, but there’s nothing else free that runs on 64 bit… ???

To update, I just re-installed the virus scan only and I’m getting the same problem, even when I have the Defense+ set to off. Seems to be this version/products, not just the firewall.

When uninstalling also delete all references to CIS in Program Fiiles, Program Files\Common Files\ , under user User and Virtualstore to be on the safe side of things.

Also clean the registry with a thorough cleaner like Comodo System Cleaner: https://forums.comodo.com/comodo_system_cleaner_fileregistryprivacy_cleaner-b124.0/ .

When trying the above does the same thing happen?

I couldn’t find anything in Programs/Common Files, and I’m not familiar with User and Virtual Store. I have a folder named Users, but that’s the closest thing I can find to what you describe. There is nothing related to Comodo that I can see in the Users folder. I deleted the Comodo folder under Programs and re-installed. It didn’t make a difference. I have AVG on my computer now, but I can’t see how that would make a difference- it justy prevents the Comodo antivirus from being activated.
Thanks for your help.

bump

Back from being out of town. Sorry for the delay.

To elaborate a bit on the relevant folders under Users. Delete all Comodo related folders under Local and Roaming. Also make sure to delete Comodo related folders under Appdata\Local\Virtual store\ .