Unable to purge Blocked Applications

I currently have Comodo installed on two machines, but one of them isn’t able to purge the Blocked Applications - when I run through the process it is displaying the “the following files are not valid” screen and allowing me to confirm, but then nothing happens and the item is not removed from the list.
I’ve tried rebooting and run through all the scans but that hasn’t resolved the issue. I can’t tell what the application/file path actually is as it is just a string of Chinese(?) characters, but I suspect it might have been a virus that has now been removed. I’ve had quite a lot of entries in the network intrusions screen as well. I did have a few similar items on both machines with the foreign characters, but all are listed as blocked by the firewall.

Any ideas why this cannot be successfully removed from the Blocked Applications? The only other odd behaviour I’ve seen within Comodo is that occasionally the application agent seems to briefly stop running with the red ‘at risk’ bar appearing then returning to green. I’ve never noticed it before, but having run countless scans on both machines with 4 or 5 different anti-virus and spyware/malware removal tools I feel fairly confident there can’t be anything malicious left on either machine(if there ever was).

It is a bug with excessive logging and thus causes corrupted log entries, you can either wait for the next stable release or install the latest beta.

Hi lemming3k,

Thank you for your reporting.Our developers are working in it,Once resolved let me notify you.

Best Regards,

Thank you both, that makes sense.