Unable to perform online lookup or do file submission,constantly wants to update

I have searched on here as much as I could and have been unable to find an answer… For some reason, about 6 months+ ago, CF has been unable to perform an online lookup of pending files and is unable to submit anything to comodo for analysis. I have uninstalled and reinstalled about 5 times, always update the software when newer versions come out but nothing fixes this.

The other weird thing is that CF updater asks to update like multiple times a day/week but never updates anything. I am not sure whats going on but after being annoyed for over 6 months, I finally decided to post on these issue.

James

Hi James, welcome to the forums.

I believe the CFP Updater uses (in XP terms) the Internet Options (Control Panel) - Connections tab to obtain its Internet connection. If you don’t use MSIE, it’s possible that something might have changed on there without you noticing.

I am having the same ‘updating’ issue, although no problem with file submission.

I have completely uninstalled and then reinstalled cfp 3.0.25.378 but the update-mania persists. The GUI reports that each update is completed successfully. It never prompts for system reboot - but if system is rebooted, or after waking - CFP prompts to update again. The version listed in ‘about’ remains 3.0.25.378.

Have tracked this over last month, when the updates seemed to go daily, but, after my 2nd update in less than 24-hours I began searching here. This is the only entry I could find. Thanks for starting this post jamesg! (:CLP) Now here’s hopin’ for an answer!

UPDATE while typing this post, CFP has just offered another update. Hmmm. Now that’s twice in about 20 minutes.

**Also to Kails post - there are no connection warnings - CFP acts as if the update is OK - but then will offer to update again and again and again . . . . .


Vista Home Premium 32b SP1 +all updates applied as of 14Jun
AVG 8.0 antivirus (cause CAV don’t love Vista, yet ) *installed after CFP - no AV running during CFP installation
BOClean - all updates current to 14Jun
CFP 3.0.25.378

Firstly, you can prevent this message from keep appearing by turning off automatic updates (Miscellaneous - Settings - Update tab). Obviously, doesn’t solve the problem… just stops it from annoying you guys.

Have either of you ever had a successful update using this process since this issue started? Does the same thing happen when you attempt an manual update (Miscellaneous - Settings - Check For Updates)?

Do either of you have something called Wireshark? We could use this to capture a PCAP session of an Update to see what happens or, rather, how far it gets.

Failing this you will probably need to go to Comodo Support, register on their system & raise a ticket on this issue.

Kail - get exactly the same results whether using auto or manual update. As far as having a successful update - who knows? CFP reports success each and every time in my case.

The install file I most recently downloaded (5/27/08) has 3.0.24.368 in name, and current verision in CFP ‘about’ is 3.0.25.378 which would seem to imply at least 1 successful update. Perhaps it implicates the offending code as well?

This started happening at the same time CFP started complaining everytime a program tried to access the Desktop Windows Manager API (dwmapi.dll) - I dont know if these are related or not, but the timing is coincidental at any rate.

Hi BNAMack

I would imagine that a “real” successful update would be characterised by CFP requesting a restart (which it always has done to date). Do all your updates request a restart?

The fact that you currently have 3.0.25.378 and your last manual install was 3.0.24.368, would indeed imply that you have had at least 1 successful update. I’m not sure what that implicates… Hmm… perhaps James has had a successful update as well… (wild stab in the dark) I’m currently wondering if CFP, for some unknown reason, is failing to remove the files it downloaded during a successful update & then subsequently detecting those files during the next update process…

Can you search your system & see how many copies of “cfp.exe” you have. By default, you should have 2… 1 in CFPs main installation directory, Firewall & 1 in a sub-directory called Repair. Thanks.

I thought restarts for firewall updates would be required as well. Tried restarting anyway but with the results previously posted.

Did search for cfp.exe

One copy in c:/Program Files/Comodo, one listed as ‘repair’ by windows in C:/Program Files/Comodo/Firewall . That appears to be normal

Where do I find the downloaded files to manually delete? Interested to see if that fixes the issue, and then if issue repeats after next successfull update.

Hi BNAMack

In XP terms I suspect (only suspect, because it’s not documented & there isn’t an update to test it against)…

C:\Documents and Settings<Username>\Application Data\Comodo\Firewall Pro\Data\TempFiles

But I don’t think you’ll find much, since I would have expected a copy of cfp.exe to be there (or at least one of the CFP installation files) if that particular theory held any water… of course, it still could be some other file (not cfp.exe) that is causing the problem.

If you haven’t already done so, it might be worth running CFPs Diagnostics (Miscellaneous) to see if it can find any problems.

Possible Comodo server-side problem? With Comodo product updates, they tend to connect to Comodo’s main server & then redirect to a server that is geographically nearer the user. The flaw with that idea is that I would have expected to see many more reports on the same issue by now if this was the cause.

Similarities between your system & James’ might also yield some clues.

ok so everything that BNA spoke about is the exact same for me. I’m running the same exact version, have Vista SP1. Whats up with the online lookup and file submission question? That has not yet been discussed. As far as the successful updates, every once in a while it will do a real update and prompt for a restart. I too went from build 368 to build 378 so it did do a successful update at least 1 time but thats about it. I am more concerned with the online look up feature and file submission. I can live with the thing wanting to update me daily but I would like to be able to cross reference files it finds and/or submit suspicious files for review.

James

Hi James

Sorry, I did not mean to ignore the On-Line Lookup or File Submission issue. Based on your first post, I originally believed (wrongly) that they were the same issue, in that whatever was preventing one was probably impacting the other. In your absence, I did specifically focus on the Update issue because that’s all there was to look at in connection with your original post.

If this issue was related, specifically, to Vista SP1 I would have expected to see more issues being raised on this. In the absence of any other information, this implies that something else is the cause. However, without any diagnostic information there isn’t a lot that I can personally do. I can only recommend that you raise this issue with Comodo Support (see above).

edit: typo

Kail - strangely (or not) the diagnostics show no problem. I wonder if this is a UAC issue with Vista? It wouldn’t be the first strange failure caused by UAC that I’ve seen - but this is only a theory.

James - sorry if the update issue took over your post. I’ve touched every single control available on CFP and cannot find where file transmission settings might be (and I’m no noob)
other than the submit files and the settings under Misc. Not much control here, though.

I do remember a similar issue with previous version. I actually caused it myself by interrupting a slow submission. Afterwards I could not manually submit files until I reinstalled and let them be submitted automatically. (under CFP - Misc - Settings) Strange steps, but it fixed my problem at the time. When you uninstalled, did you follow the instructions available on this forum for complete un-installation? Firewalls are tricky beasts to remove!

Good luck - and I’ll ■■■■ out of your post now. (:SHY) (:WAV)

sorry - one more

Kail - as for the temp files. I found c:/users/‘username’/AppData/Local/Comodo/ComodoFirewall/Temp/ as the Vista analogy to the path you suggested. We might need a new theory - the folder was empty.

thanks again for trying.

Mack

Hi Mack

Diagnostic info: Sorry, my fault. I didn’t mean CFPs Diagnostic function (that doesn’t produce any output, it’s more a Repair utility) in my last post (to James). I actually meant a Wireshark PCAP of CFPs Update attempt (I think your UAC idea has more merit at this point anyway).

UAC: Now that is a possibility. I don’t use Vista, so I don’t know enough about UAC to ask any sensible questions. What I’ve read about UAC is that some people swear by it, whilst others seem to swear at it. Let me try & drag some more Vista users into this topic.

Temp files: A forlorn hope, but worth a try. Thanks. But, I gather the File Submission issue might be similar issue (file/registry traces left behind) based on your experiences with it.

Hey guys,

On request I’ve read this through and have been thinking a bit how this could be resolved.
So here comes my try :),

First uninstall Comodo with revo uninstaller (advance mode and kill all remaining leftovers and then cleanup with this tool.

restart

Reinstall using these links
32 bit
64 bit

Then install, only the firewall with defence + , no toolbar and no antimalwarecheck

Restart

If you still have problems with the updates take a look at these threads
first one
second one
third one

look at this thread if you use UAC control and you’re not sure if it’s configured correctly

Post back if it still gives the update problem or if it is resolved of course :wink:

Xan

Xan

Thanks for the suggestions and links. Have downloaded the tools you suggest and will advise on outcome.

!ot! As for the UAC annoyance issue - to be honest it is no more annoying than the popups generated by programs like CFP and CAV. Of course I haven’t had anywhere near the number of issues with Vista that are repeatedly (and gleefully) reported in the 16 months I have been using it. (run Vista 32 Home Premium SP1 on a middle-of-the-road AMD Athlon dual core 64x2 3800+ (2.0Ghz each core) with 2GB RAM)

Ok - tried your suggestion, Xan, with the following results:

I noted that after this installation, Windows complained of the drivers used by CFP. After the first reboot I had to run the CFP diagnostic tool, which tried to reinstall the drivers in question. At that point Windows Security popped up the ‘unsigned driver’ warning and I had to OK using CFP’s drivers. There were no prompts of this kind during the install. This did not happen at all with the 3.0.24.368 install file. (this time used current installer available on the website - 3.0.25.378). After running the diagonostic tool and rebooting the machine again, I tried manual update and was told the update succeeded, but again there was no prompt for reboot. I rebooted anyway, and CFP popped up an Update Alert almost immediately. The version number in ‘About’ still reads 3.0.25.378. The links to info on the update being offered went to the 3.0.25.378 info page.

As for toolbars - never installed (admitted tool-bar hater, here). I did skip the malware scan this time per your suggestion, but it didn’t seem to have any impact.

Followed the links to other forum entries. The first two seem to be about not being able to even start or complete an update. This doesn’t seem to fit my situation. CFP appears to go through the motions of a successful update, including Progress bars.

The third link suggested deleting from the roaming/appdata/comodo… file – all I found in the /resfiles folder were icons, bmps, pngs, etc. and 2 .ini files. The first, ‘config.ini’ seems to only deal with the look/layout of CFP. I then opened ‘prdinfo.ini’ which had the following info:

[INFO]
ProductName = COMODO Firewall Pro
ThemeName = Default

[UPDATEURLS]
xp_32=http://download.comodo.com//cfp//download//updates//beta//xp_32_cfp_update.ini
xp_64=http://download.comodo.com//cfp//download//updates//beta//xp_64_cfp_update.ini
vista_32=http://download.comodo.com//cfp//download//updates//beta//vista_32_cfp_update.ini
vista_64=http://download.comodo.com//cfp//download//updates//beta//vista_64_cfp_update.ini

But this did not suggest a solution, at least to my eyes. Again, CFP doesn’t seem to have any problems connecting in my case.

I thank everyone for the suggestions. Sure hope this is fixed soon. For all practical purposes I have no idea if my firewall is being updated at all. I have turned off update notification for the sake of a quieter desktop and will use the manual option and hope for the best in the meantime. :-\

**updated to correct typos and update info on suggested forum links