Unable to load any webpages during certain times

I’ve been having this problem for about the past month or 2. It’s getting somewhat annoying since I have to have Dragon constantly open. I can confirm that this only happens to Dragon and not my other browsers (Chrome, Waterfox/Firefox, and Opera). I’ve tried pretty much everything from re-installing to re-configuring my router. I can confirm that every page that I have open in Dragon does work on my other browsers. I attached my dxdiag if it helps. The times that this happens is between the morning at 7 am to about 4 pm. I also tried the portable version of Dragon and it’s the same thing. There are no errors whatsoever.


I did a tracert and pinged Google and both came back clean.

[attachment deleted by admin]

…if you have “enable malware domain filtering (comodo secure dns)” checked in “settings → show advanced settings → privacy” - try unchecking it - close & reopen dragon - try that…

Nope. That didn’t work.

…keep checking back until a moderator responds to help…

Did you try running without extensions? Are the drivers of your graphics card up to date?

Yep. Ran it without any extensions on and still got the same thing. Surprisingly it didn’t work at the times I said before. It worked from about 4.30 pm to about 5 pm. Now it won’t load any webpage (time now is 5.30 pm). Drivers are up to date too.

Hi Synopis,
This is a bit weird.
What are the steps taken to reproduce this issue, can you still search?

What are your connection settings in Dragon, found under Network in Advanced Settings?

Perhaps it has something to do with the Spamhaus DDOS war.

Probably an obvious question, are you using a proxy in Dragon? Failing that, I’d suggest opening:


From the address bar and looking at some of the information - you can post here if you’re not sure what it means. Look particularly at:


Also, pick any URL you normally connect to and use the ‘Tests’ option on the same page to see what happens.

Unfortunately I can’t connect to Google when this happens which means I can’t really search for anything. I can connect to Google while on my other browsers. As far as reproducing the issue…I just close Dragon during a certain time and just open it during whatever times I can’t load anything. Attached is the network configuration.

I did a test for www.google.com and everything passed. Still can’t connect to it. I attached pictures from the net-internals.

[attachment deleted by admin]

Just to confirm, these images are when you’re unable to connect? looking at these I’m assuming this is correct, as the DNS cache entries have all expired and there doesn’t appear to be any bytes being sent. Would you mind doing one more check.

In the Events section, if you select an entry on the left you’ll get some detail displayed on the right. Can you select a couple of entries under URL Request (for a real domain) and Stream Request and post the detail from the right side window.

Also, in settings under Network, can you change the setting to Use Direct Connection and see what happens.

I got the url_request’s but I haven’t seen any Stream Request’s. Using direct connection under network doesn’t work either.

[attachment deleted by admin]

Hi Synopis,
You could try to portable version to eliminate any Dragon user profile issues.
This will not effect your installed version.

Installed and got the same thing.

Try deselecting ‘Automatically Detect Settings’ under your LAN Settings.
Sorry I have got no other ideas at this stage.

Automatically detect settings haven’t been selected for the past 3-4 months.

May I ask, which security applications you’re using?

Hello Synopis,

Are you using any network monitoring or security applications?

Thank you.

Just Avast and Comodo firewall, but I usually run the firewall in game mode most of the time. I run Malwarebytes a couple times a week.

Just the security applications as stated above. As far as network monitoring… No.

Please try this:

  1. Disable all antivirus and firewall software temporary.
  2. Run dragon.exe with command line argument --disable-plugins.

Some question:
Does this problem occurs on all computer in your home network or just one?
Are you able to open your router administration interface in Dragon?