Unable to install CRC

I downloaded the file:
but when I try to install it, all I get is this message:

You Operating System does not meet the minimum requirements to run this application!
I don't mind the spelling mistake, but I fail to see how my OS is inadequate for the task, given that the download page includes a mention of XP64, & I'm running a fully patched & up-to-date XP64 SP2.

Ditto… on XP64 SP2 and won’t install. :frowning:

Well, it sure is strange. ???

I guess the only way to have a clue here would be if you provided more system details, like currently installed software, and software you’ve uninstalled. But that’s just me guessing, the expert is Andrei and some other guys.


ps. welcome to the forum!

I can’t help to guess that the install routine in mistaking XP64 for Server 2003(which often happens since XP64 is an OS built on server 2003 and not XP). SP2 is the latest available for XP64 but CRC requires SP3 for Server 2003.

BTW CRC installs fine.

Among the products I have running are Comodo Firewall Pro and Nod32 (… and I have tried disabling them).

I suppose this is important…?

Thanks for sharing.


Too much to list really, though from reading some of the comments about CRC I’m not sure I want to try it on my main install anyway. Once I’ve done the complete rebuild/reinstall of my machine I might give it a go in a VM.

As to the issue of SP3 that someone mentioned, for anyone not familiar with XP64, there is no SP3 for it, & there doesn’t even appear to be 1 planned for it. :frowning: Then again, it’s not so much the service pack that’s important, as it is what’s in it, & MS are still doing updates for XP64, so maybe Comodo needs to change the install check to look specifically for whatever it needs, rather than just checking the service pack number.


Please standby for the update which is scheduled for tomorrow. This problem is fixed in this new version.

Read this post as I am having same problem as Alien42 – Running fully patched and up-to-date XP Pro x64 SP2 but get “You Operating System does not meet the minimum requirements to run this application!” error message… Today I downloaded CRC_Setup_1.0.12.16_2k_XP_Vista_Server2003_x32_x64.exe again but issue is still not resolved-- same error message. >:(

I think we’ll have to wait for


ps. welcome to the forum :wink: