Unable to install CIS 6 Final on Win 8 due to Solutu [M129]1[v6]

  1. Solution::
    Uninstalling soluto (www.soluto.com)

Unable to install CIS6 final on Win8 64 bit

  1. What you did:
    Download and try to install CIS
  2. What actually happened or you actually saw:
    It stopped with 99% saying "Cannot install COMODO Firewall. Error: 1603. Fatal error during installation.
  3. What you expected to happen or see:
    Finished installation.
  4. How you tried to fix it & what happened:
    I tried to reboot several times. I tried to run setup as administrator (even my normal account has admin rights).
    I uninstalled the start menu replacement (Classic Shell) and used the Uninstaller Tool v0.3b from the forum.
    I did a restart after every step.
    I tried to use the firewall only installer and the normal installer.
  5. If a software compatibility problem have you tried the compatibility fixes (link in format)?:
  6. Details & exact version of any software (execpt CIS) involved (with download link unless malware):
  7. Whether you can make the problem happen again, and if so precise steps to make it happen:
    It always happens trying to install CIS.
  8. Any other information (eg your guess regarding the cause, with reasons):

B. FILES APPENDED. (Please zip unless screenshots).:

  1. Screenshots of the Defense plus Active Processes List (Required for all issues):
    as I cannot install, I cannot get that list. I attached a killswitch log. Does this help?!
  2. Screenshots illustrating the bug:
    screenshot see here: https://forums.comodo.com/beta-corner-cis/is-version-602607392674-still-a-beta-t89172.0.html;msg643498#msg643498
  3. Screenshots of related CIS event logs:
  4. A CIS config report or file:
  5. Crash or freeze dump file:
  6. Screenshot of More~About page. Can be used instead of typed product and AV database version:


  1. CIS version, AV database version & configuration:
  2. a) Have you updated (without uninstall) from a previous version of CIS:
    Yes. First I tried to install CIS 6 without uninstalling CIS 5.12.
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:
    I did.
  3. a) Have you imported a config from a previous version of CIS:
    I couldn’t, because it’s not installed.
    b) if so, have U tried a standard config (without losing settings - if not please do)?:
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.):
  5. Defense+, Sandbox, Firewall & AV security levels:
  6. OS version, service pack, number of bits, UAC setting, & account type:
    Win 8 Pro with Media Center, x64, UAC is off, admin account
  7. Other security and utility software currently installed:
    MS Defender
  8. Other security software previously installed at any time since Windows was last installed:
    Only MS Defender, CIS
  9. Virtual machine used (Please do NOT use Virtual box)[color=blue]:

[attachment deleted by admin]

Sorry you are having this problem

Are you using a third party start menu replacement?

(And please if you would add as mch as you can of the missing information in the bug report. It will help us to help you :slight_smile: )

You can download Killswitch from here. Though this is the full version with CCE - these are powerful tools so please be careful how you use them

Best wishes


I do. Classic Shell. http://classicshell.sourceforge.net/

Can you see if what I wrote in this post in the release topic is applicable on your situation?

Thanks for your quick reply and help!


No, I didn’t find any hidden things there. I never installed a CIS6 beta. So I think it’s not applicable.

I attached a killswitch log above.

I uninstalled my third party start menu replacement and used the CIS uninstall script from the board. Alway with restarting my PC in between. Still no success. I’m even not able to reinstall CIS 5.12 again :cry:

CIS 5.12 is up again. Uninstalling, cleaning script and some restarting did the trick. At least.

I think I’ll wait for the in-App upgrade and give CIS6 a try again then.

Thanks for listening!!

I just did :slight_smile:

Thanks, appreciated. My guess is the start menu. If you feel moved to install CIS after removing it, just as a test, it would be great to know the result.

I had a problem with my start menu extender and CIS

Best wishes


I already did and reported. I’m no going through all steps again. Uninstall CIS 5. Restart. Use cleaning tool. Restart. Uninstall Classic Shell (again). Restart. Try to install CIS 6.

I report back again then. Will take half an hour.

No that’s fine, no need to do it twice, so long as you did it thoroughly first time. I did not read carefully enough mea culpa


Four restarts later I see: you were right. Doing it twice doesn’t change anything :wink:

But at least I got an extra error message via windows event view.

- <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
- <System>
  <Provider Name="Application Error" /> 
  <EventID Qualifiers="0">1000</EventID> 
  <TimeCreated SystemTime="2012-12-19T22:04:09.000000000Z" /> 
  <Security /> 
- <EventData>
  <Data /> 
  <Data /> 

I got it!

Trouble was caused by soluto (www.soluto.com). Uninstalling solved all problems. Found it by looking at the windows event log.

Well done. If you exclude soluto from the behavior blocker does it work? Try just the .exe first, if that does not work the whole directory.

To install CIS it wasn’t enough to disable (set to deactivated) all soluto services. I had to uninstall soluto completely. Perhaps I should have removed soluto from autostart in registry, but I didn’t mind it. I, as said, only disabled all services with no success.

After installing CIS I reinstalled soluto to see if this affects CIS in any way. It doesn’t. I was able to install soluto with CIS running without getting any problems. CIS keeps running well as well as soluto does.

OK makes sense. I think Solutu is installing a driver, and that’s interfering with the CIS installer. If so it may be visible in the location Eric referred to, or you may have to seek it out in System32 or 64\Drivers.

If you fancy another experiment, you could take a restore pt, disable the driver (just rename it), reboot, then uninstall CIS, then reboot, then install CIS.

Disable driver is first in case it interferes with uninstall.

Best wishes


Couldn’t see anything from Soluto (or Comodo) there. Took a quick look at System32/64 and didn’t find anything from soluto there. But it was only a quick look.

I’m not sure about how to go on. If it does help anyone I’d take some time and do some more tests. But right now I’m not sure if I’m wasting my time or doing something useful. For me everything is just fine. So no need for help anymore.

Again: if I can do something to help anyone else: I’m up for it!

Thanks I appreciate your help.

I’ll let QA get in touch if they wish

Probably will be resolved in an update…


I’m going to forward to format verified rather than resolved as I think QA will probably want to fix this.

Best wishes