Unable to export the configuration.

  1. i see this massage when export configuration.
    i used without a problem Until yesterday. Suddenly today, I see this message.

COMODO Internet Security Premium

Unable to export the configuration.
Please make sure you have enough rights for the path.


  1. To force the export COMODO.cfgx file was automatically deleted. Why?

My account : Administrators
OS : Windows XP SP3 EN
Other Secure Program Setup : Malwarebytes Free
Product Version : 5.0.162636.1135
Virus Signature Database Version : 6836

[attachment deleted by admin]

I suspect write permissions on the location where you tried to save the file…
Can you please verify if e.g. save to Desktop resolves the issue?

An other issue could be that cfp.exe is running with limited permissions do you use some sort of “drop-my-rights” like tool or is cfp.exe running in EMET from Microsoft?

I’ve had this and the configuration within the registry was corrupt somehow.
I imported a previously saved cfgx file and I was able to export it OK.

CIS also occasionally corrupts the log files as well going from 1MB to 7MB of junk but nothing appears in the log files windows.


Thanks for Ronny,MSB.

Removed the ‘My Setting’.

after resetting at useing the Proactive config ,does not seem to error.

Perhaps this say is right thing. :a0 :-TU

[attachment deleted by admin]

I have this problem too:


I can save the other three, but not Proactive Security.

Since I have no previous saved configuration, I can not import one first.

What can I do?

what happens if you switch to an other profile (active) first and then try to export the ProActive profile?



In June it worked for some reason. It worked in October and November. In March it worked and in April it … worked. It is May again and it does not work. ((Well that is pretty funny to me, but actually it worked indeed on the 6th of may!))

  • Windows XP Professional
  • Comodo Internet Security Premium 5.12
  • I could export and import my configuration COMODO-Proactive-Security-old-5.12.256249.2599 for months
  • I can import older configurations
  • I can export older configurations
  • I can not export my COMODO-Proactive-Security-old-5.12.256249.2599
  • I did reboot my computer
  • I changed the active configuration without an impact
  • I made sure, it has nothing to do with the length of the file name and configuration name
  • I tried to save it in another folder and on another drive



It sounds like a problem with access rights to the registry key that holds that profile. The profiles can be found in HKEY_LOCAL_MACHINE\SYSTEM\Software\COMODO\Firewall Pro\Configurations.

You need to do a take ownership procedure on that key and subkeys: http://www.mihirbabu.com/2012/05/how-to-take-permission-ownership-of.html .

I hope that helps.

I did so, while I do not understand all instructions in detail.
But it did not help, can’t export.

I used import for an older configuration and looked at its permissions. Everyone has full control of regitry keys of imported configurations. Which did not help my current configuration.

What next?

I am not sure what else it could be. Ronny do you have an idea?

Other than that I can only assume the configuration its self may have gotten corrupted… :-\

Sysinternals Process Monitor is likely to reveal what goes wrong. I just don’t have time right now to guide one trough so if you could Eric?

I have no experience with Process Monitor… :-\

It’s a tool that runs a trace of file/registry etc actions on the system.
If the trace is run for a short time and the action of saving is done and has failed we need to stop the trace and analyze the output.
If you could manage to get the trace I can have a look at what’s going wrong.