Unable to delete batch files after virtualization in Windows 10 [M1785]

Can you reproduce the problem & if so how reliably?:
Yes. Every time.

If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1: Right click a .bat file
2: Select “Run in COMODO Sandbox”
3: Try to delete .bat file

One or two sentences explaining what actually happened:
You will get the following error : [File In Use] The action can’t be completed because the file is open in another program.
One or two sentences explaining what you expected to happen:
You should be able to delete .bat files after virtualization & execution.
If a software compatibility problem have you tried the advice to make programs work with CIS?:
N/A
Any software except CIS/OS involved? If so - name, & exact version:
N/A
Any other information, eg your guess at the cause, how you tried to fix it etc:
Seems to be specific to delete action, other actions (eg rename) pose no visible problems.

B. YOUR SETUP
Exact CIS version & configuration:
CIS 8.2.0.4978, Configuration: Internet Security
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
Default
Have you made any other changes to the default config? (egs here.):
No.
Have you updated (without uninstall) from CIS 5, 6 or 7?:
No.
if so, have you tried a a a clean reinstall - if not please do?:
Yes.
Have you imported a config from a previous version of CIS:
No.
if so, have you tried a standard config - if not please do:
N/A
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 10 x64
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
None.

Can’t replicate.

Ditto here. After I got an alert saying the bat file had been run virtually, I was able to delete the bat file without issue.

Cheers,
Ewen :slight_smile:

VIDEO

I will remove attachment after April 8

Please attach a diagnostics report.
main interface window > question mark (?) > support > diagnostics

VIDEO 2!

Stop play/disbelieve your users.
Fix this bug AND hybrid Rules bug please.

I will remove attachment after April 8

This isn’t a comodo bug, Windows doesn’t release the handle to the file after the file is no longer opened. Also just by browsing to a folder will sometimes have the files be opened without ever opening the file, by the System process which is the Windows kernel. I have notice this behavior even when I didn’t have CIS installed. You just need to wait awhile for System to close the handle before you can delete the file, or doing a reboot will force the handle to be closed by System.

Seems to be specific to Windows 10 & batch files & delete action. Replicated on a virtual machine. I will check it.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

I was informed that it’s not a CIS issue. Also, Shift+Del seems to work.

Hope it helps.