Unable to Connect to My Wireless Router While Comodo is On

I have this strange problem.

Sometimes when I reload my computer Comodo allows my wireless connection to establish. Most of the times though I have to turn Comodo off for my connection to establish and then turn on Comodo.

Any suggestions?

Security level is at Custom.
Compenent Monitor is at Learning.
Trusted Zone has my wireless network adapter listed along with the IP range which includes my wireless router.

Any help will greatly be appreciated.



I’ve got a problem that is probably related to yours.
Browsing the Internet has been going veeeerrrrrryyyyy slow lately!
I’ve tried dozens of things but nothing helps. Then I’ve tried to put the Comodo Firewall to Allow All and suddenly I can browse the Internet on a decent speed, not even the speed I was used to.

Can anybody tell me what the problem or why the firewall blocks some unnecessary things?

Please help us asap.


Hi There!

Eragon482, my issue has more to do with just basic network connectivity. I cannot connect the my router. Sometimes I can but then again there are times that I cannot. My signal strength is at excellent or above 80% so its not a signal issue. It seems like even though my router is in a Trusted Zone I am unable to connect.

Any help with this will greatly be appreciated.


I guess I will just have to uninstall this PoC…

Thanks Guys…


Some of this may help:



This may be due to the logging carried out by the firewall. You could try disabling logging to see if there is any improvement.

In network monitor right click any block and log rules and select edit. Uncheck the box ‘create an alert if this rule is fired’.

You can always turn this back on later if you wish.

Another option which can help and will still allow you to view some log events is to make the log file itself read only:

Log Files usually at: C:\Documents and Settings\All Users.WINDOWS\Application Data\Comodo\Personal Firewall\Logs

Right click the file and make it read only. This drastically reduces the drain on your system in most cases. Worked for me and many others.