Unable to bookmark, show and use History/bookmarks library

I’m new to Comodo and Ice Dragon. I was looking for an x64bit version of my favorite browser, Firefox.

After downloading and installing, I was really taken with Ice Dragon. It is the answer to what I needed for both security and speed. However, I have a problem with the imports and usage of history, bookmarks, various profile items and the direct bookmarking of sites I go to.

I can import and use bookmarks from another browser, but the library page will not populate. Also the history library will not even show and I need to sort thru and clean up what was imported from both. There may be more in this area, but I haven’t seen yet.

What can I do to remedy this if it is of my doing??

Thanx in advance for your help,

andythebeagle, Rochester, NY

Operating System
Windows 7 Home Premium 64-bit SP1
Intel Core i3 540 @ 3.07GHz 42 °C
Clarkdale 32nm Technology
8.00GB Dual-Channel DDR3 @ 664MHz (9-9-9-24)
Acer Aspire M3910 (CPU 1) 30 °C
ASUS VH236H (1920x1080@60Hz)
512MB ATI AMD Radeon HD 6450 (Sapphire/PCPartner) 52 °C
465GB Hitachi HDS721050CLA662 (SATA) 44 °C
1863GB Seagate ST2000DL004 HD204UI (SATA) 42 °C
29GB SanDisk Cruzer Glide USB Device (USB)
Optical Drives
Realtek High Definition Audio

I’m gonna mark this as solved. I did a complete re install and a sys restart. When I did that and then imported everything, it all started working, not perfect, but working. I tried to book mark a page and it didn’t work. Restarted Ice Dragon and the bookmark function works now. However, the library for bookmarks and the history library will not populate. I’ll look around to see if something needs done. I sometimes miss things.