Unable to access shared folder over LAN

Hello,

I’m trying to access a shared folder on my PC (running XP) over LAN. Everything except Comodo is set up correctly - I can access the shared folder when I disable my Comodo Firewall. With Comodo enabled, I still see my PC in the network, but I can’t get access to the shared folder.

I’ve set up my local network zone (192.168.1.1/255.255.255.0) in Comodo and created a global rule with the Stealth Ports Wizard, but Comodo still blocks access to the shared folder. The same happens when running Comodo in Training Mode, without anything being learnt. The firewall log doesn’t show any blocked connection attempts and I don’t get any alerts (I’ve set up Comodo to alert me about pretty much everything).

Any ideas about what else I could try? Help would be greatly appreciated!

I’ve compared the two connection attemps (one with Comodo running and one without Comodo) using Wireshark. It looks like things are starting to go wrong when the PC running Comodo doesn’t respond to a packet it receives on port 445 (microsoft-ds).

So, the new question is: Why does Comodo block a request on port 445 coming from an IP that is in my local network zone?

My Global Rules look like this:
Allow All Outgoing Requests If The Target Is In [LAN]
Allow All Incoming Requests If The Sender Is In [LAN]
[the default ICMP rules]

The first two rules are set to allow Protocol: IP, IP Protocol: Any.

My LAN zone is set to 192.168.1.1/255.255.255.0, the sender of the above packet is 192.168.1.34.

The Application Rules do not contain any blocking rules (only an allow all from LAN for the System process).

Open CIS, click the Firewall tab. Then, click My Port Sets.

Click Add > A new port

Enter in 445. Click Apply.

Make sure you drag the port down to privileged ports. Click Apply.

Now try this again, and tell me the results.

I appreciate the default settings for a new trusted Zone is to Allow IP but you might try changing this from IP to TCP-UDP, I’ve seen it make a difference in the past.

Thanks for your answers! I tried both suggestions, unfortunately with no luck. The connection attempts still look the same.

I found out some more things:

  • Comodo does show an alert for port 445 when I remove the allow all rules, but allowing that connection request doesn’t seem to make a difference.
  • I forwared port 445 on my router and did a port scan from an external website (which I added to my LAN zone for the test). With Comodo, the port is shown as stealthed, without Comodo it is shown as closed.
  • Things are still the same after a reinstall