Unabel to access certain websites


I am an old ZA used and now using Comodo Firewall(v3.0.25.378). I am unable to access some websites. I am getting the following message when using IE(Same occurs in Firefox)

Internet Explorer cannot display the webpage

I have tried disabled Comodo, any AV, ran spyware etc and have had no luck. I went through and reset all my TCP/IP settings, cleared arp cache, cleared DNS cache etc…etc…etc… All with no help.

I was playing with my Network settings and unchecked the box for “Comodo Firewall Driver” and that fixed it! When rechecked the problem reoccurs.

I have tried adding custom rules for my browser and the websites and those have failed.

What can I do to resolve this besides switching back to ZA? (ick).

I am running Vista 32bit. Website examples are(At first I thought it was related to .ca domains)


Many thanks in advance!

Good day,

very weird you can not visit certain websites… I think the comodo firewall driver is a very important component of the firewall, I think its main function is too check if the network settings are set correct. In order to verify if your network settings are correct, you can check the network security policy, and see if you can see some strange rules…

check if you can something strange in my blocked network zone…

check if you installation has been correct, by running the diagnostic tool… also check if you can see something in the logs…

DrmChld, welcome to the forum.

Can you ping (www.cic.gc.ca’s IP)?

I am able to trace and ping to the sites just fine.

If you can ping by addy as well then there is a connection - just might not be with the browser. That or it could be a DNS issue with your ISP.

I thought of this as well. However, I am able to trace and ping to the hostname. My wife’s PC is able to access the sites fine and they work fine on my PC if I uncheck the Comodo Driver from Network. I have also tried various ISP DNS server addresses without luck.

The problem is somewhere with Comodo :frowning:

In that case set IE using the predefined rule “Web Browser”. That’s what I had to do for setup.

[attachment deleted by admin]

Nothing seems strange in there to me. IE was set to Custom, I have changed this to Web Browser and no luck.

Under My Blocked Network Zones nothing is listed.

Diagnostics show installation is correct.
Event logs show nothing as being blocked or denied for these sites (or any).

Whatever the problem is, it is related to Comodo. Just tracking it down has been an issue for me. Nothing is being logged or reported when the sites are accessed. When I uncheck the Comodo Network Driver the sites work fine. If I recheck it, the sites don’t work anymore.

I’m lost.


If your PC is on a network you may have to go to Firewall > Common Tasks > Define a new Trusted Network

On second thught - I suppose what I mentioned a useless since you “have tried disabled Comodo” already :-[.

Quick reply :slight_smile: I was posting a reply to a previous post that suggested checking this settings. This was changed from Custom to Web Browser without any luck.

What is really odd, Is the URL Icon is being retrieved from the server but the web page isn’t being displayed. As in the case with the cic.gc.ca website the maple leaf icon appears for the URLand Tab with the IE message saying the website cannot be displayed.

For those sites that you can access, they’re not cached, are they?

I’ll be off to work now. May drop by later on today :).

try to clean all temporary internet files and maybe you should try to do a reinstall of the firewall…

Check CFP logs to see if anything got blocked.

If you reinstall, ensure existing security and utilities are off to minimize potential conflicts.

Cache has been deleted. I also tried the IE Reset (Tools, Advanced Tab, Reset button) which resets IE back to Vista base install.

Which makes me ponder why the URL icon shows up

Logs are empty. Going to try a clean install.

Crossing fingers!


Uninstalled, checked reg for any signs of comodo, etc… reinstalled. Still no luck :frowning:

When you disabled the Comodo driver in “network”, do you mean the Device Manager?
What are your other security software?
Have you tried to reinstall your NIC driver?

I disabled the Comodo Driver by unchecking the box for it in the properties of my network connection. Running AVG for antivirus/spyware, no other firewalls. Windows firewall service is disabled.

Have not tried to reinstall NIC drivers, didn’t think that would interfere or cause a problem.

Just running out of ideas :-[.

I assume you’ve confirmed that all references of your previous firewall have been cleaned out?

There have been some reports that installing in safe mode works in unusual cases.