Ubisoft Game Launcher - no active connection error [310]

The bug/issue

  1. What you did:
  • Trying to play Splinter Cell Convition.
  1. What actually happened or you actually saw:
  • The game updates without any problems. The Ubisoft Game Launcher updates without problems as well. After logging into my Account through the Launcher I’ll get the error message, that I don’t have an active internet connection. The Ubisoft Game Launcher can’t update his log files as well.
  1. What you expected to happen or see:
  • The Ubisoft Game Launcher connects to the Ubisoft Servers and starts Splinter Cell Convition or at least updates it’s log files with connection errors.
  1. How you tried to fix it & what happened:
  • I’ve tried gameing mode.
  • I’ve deactivated D+ completely and gave every EXE and DLL file from Ubisoft Game Launcher and Splinter Cell Conviction full internet access in the firewall.
  • I’ve tried to give every DLL and EXE from Ubisoft Game Launcher and Splinter Cell Conviction the D+ rights for “Installer/Updater” and full internet access in the firewall.
  • I’ve tried to add every DLL and EXE from Ubisoft Game Launcher and Splinter Cell Conviction to the D+ Execution Control exclusion and full internet access in the firewall.
  • I’ve completely removed CIS, reinstalled ONLY the Ubisoft Game Launcher and made sure it works. After that, I’ve reinstalled CIS. After CIS was reinstalled, I’ll get the error message with no active internet connection again.
  1. If its an application compatibility problem have you tried the application fixes?:
  • Yes.
  1. Details (exact version) of any application involved with download link:
  • Splinter Cell Convition: Automatically updated to V1.04 after start.
  • Ubisoft Game Launcher: Automatically updated to V1.0.0.1 after start.
  • No download link for both since you have to buy the game.
  1. Whether you can make the problem happen again, and if so exact steps to make it happen:
  • Install Splinter Cell Conviction together with CIS. After that try to run it.
  1. Any other information (eg your guess regarding the cause, with reasons):
  • I think it has something to do with the Ubisoft Game Launcher since it can’t connect to Ubisofts Masterserver. To make sure I would need other Ubisoft games with their actual online copy protection.

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug:
  2. Screenshots of related CIS event logs and the Defense+ Active Processes List:
  • Logs and process list added as attachments. Please note that the actual date would be 2010-11-20 There are older log entries from 2010-11-19 where I reinstalled the firewall after a complete uninstallation.
  1. A CIS config report or file.
  • Config file added as attachment.
  1. Crash or freeze dump file:

Your set-up

  1. CIS version, AV database version & configuration used:
  • CIS version: 5.0.163652.1142
  • AV database version: 6780
  • Configuartion used: COMODO - Internet Security, COMODO - Proactive Security, COMODO - Firewall Security
  1. a) Have you updated (without uninstall) from CIS 3 or 4:

    • No.
      b) if so, have you tried reinstalling (if not please do)?:
  2. a) Have you imported a config from a previous version of CIS:

    • No.
      b) if so, have U tried a preset config (if not please do)?:
  3. Other major changes to the default config (eg ticked ‘block all unknown requests’, other egs here. )

  • Nothing.
  1. Defense+, Sandbox, Firewall & AV security levels:
  • D+= Tried every level
  • Sandbox= On and Off
  • Firewall = Tried every level
  • AV = Tried every level
  1. OS version, service pack, no of bits, UAC setting, & account type:
  • OS version: Windows 7 Professional x64
  • UAC setting: Tried on and off
  • Account type: Tried normal user and admin
  1. Other security and utility software installed:
  • Nothing. Windows Defender and Firewall are deactivated.
  1. Virtual machine used (Please do NOT use Virtual box):
  • No.

[attachment deleted by admin]

THanks for a very helpful bug report in standard format.

Please try these solutions here and report back. For the moment I will transfer you to help so you can benefit from other’s experience. Please ask any mod to move this report back to the bugs forum if it turns out you cannot resolve this.

Best wishes


Hello mouse1.

Thanks for the link to some possible solutions. I’ve tried them already and they couldn’t solve the problem. Actually, I think it’s not a problem with the sandbox. This problem occured before the sandbox was introduced into CIS.

On the Ubisoft forums you get the answer, that the only way is, to completely remove CIS from your system. When using their Tech Support Center and asking about a way to solve this, they only say that it’s an application compatibility problem.

Maybe someone from COMODO has more luck with talking to the guys from Ubisoft. Understandable that they won’t give out detailed informations on how their copy protection works. At least not to the normal user, who want’s a secure PC.

OK was judging by your answer to ‘the bug/issue’ number 5. Should have read further

Moving back


Could you paste your firewall and D+ logs please into your first post after rebooting and trying to run Ubisoft? Also your active processes list when trying to run Ubisoft.

Many thanks


Added them as attachments. I’ve also modified the answer to number 5 so there’s no more misunderstanding.

The process list is a jpeg and the log files are html created by the export funtion in CIS.

Thanks for an excellent bug report.

Forwarding now to format verified


Hi. Is there any news about this issue? I’ve experimented the same problem here: the Ubisoft Game Launcher updates without problems but after logging into my Account through the launcher I get the error message, that I don’t have an active internet connection. That happens both with splinter cell and assassin creed 2. I see that in ubisoft forum, many people have the same problem. I was forced to uninstall CIS to play these two games. :cry:

hey and warm welcome to Xernox

I have read it very fast and if I right your games gives buffer overflow which will give problems. This is how you solve buffer overflow attack CIS —> Defense+ —> Defense+ Settings —> Execution control Settings —> Detect shellcode injections (i.e. Buffer overflow protection) —> Exclusions —> Add —> Browse…

Make sure that the firewall is not blocking your games. this is how you add them in the firewall. CIS —> Firewall —> Network Security Policy —> Add —> Select —> Browse… Now you have search for the wanted file

I have seen that some online games require certain ports. I will give you an example how to add a port (allow/block). But don’t add this port!

By EricJH

To open the port TCP 1723 for example

First step is to determine the MAC or Physical address of you network connector. Go to Start → Run → cmd → enter → a black box will show up and enter the following → ipconfig /all (notice the space before /all) → enter → now look up the Physical address and write it down.

Notice that Physical address = MAC address

Firewall → Network Security policy → Global Rules → Add → fill in the following:
Action: Allow
Protocol: TCP
Direction: In
Description: Incoming Port

Source address: Any
Destination Address: Choose MAC address and fill in the found MAC/Physical address
Source Port: Any
Destination Port: 1723

Then push Apply → Now make sure that the new rule is somewhere above the basic block rule(s) as the bottom (the block rules have red icons); you can drag and drop the rules → Ok

You need to make your local network a trusted zone.

First look up your IP address and subnet mask. In Windows go to Start → Run → cmd → enter → ipconfig → enter → now lookup your IP address and subnet mask.

Second create a zone in My Network Zones (Firewall → Network Security policy). Choose Add → A New Network Zone → fill in a name like My local network → Apply. Now select My Local Network Zone → Add → A new address → choose An IP Address Mask → fill in your local IP something like 192.168.1.x usually and your subnet mask; usually → Apply. Now check and see the new network defined. Exit using Apply.

Now we are going to use the Stealth Ports Wizard to make your local network a trusted network:
Choose “Define a new trusted network and stealth my ports to EVERYONE else” → Next → choose “I would like to trust an existing My Network Zone” → choose your local network zone from the drop down box at the bottom → Finish.

Now check your Global Rules and see your network added.

I am sorry that is long but I wanted to give a hand :slight_smile:

Merry Christmas to you all!

Valentin N

thanks for your answer Valentin and Merry Christmas to you! Unfortunatelly I did not receive any buffer overflow alarm from CIS when I tried to play those games. Also I added the executables to buffer overlow exceptions and to my safe files both in D+ and in the firewall with no result. So my question is (correct me if am I wrong, I’m not an expert) if a game is added as trusted to the firewall, is necessary to open single TCP ports to play it?
The files in my safe list don’t have already full internet access?


Hey Dave!

you should only add/open, in case, open the required TCP ports, if the online games says so and if the game exe file is not in Application Rules. Normally is should be enough by adding the exe file in application rules (CIS —> Firewall —> Network Security Policy —> Application Rules). Have you done that? This how you add an application in Application Rules:CIS —> Firewall —> Network Security Policy —> Application Rules Add —> Select —> Browse…
Once you have added an application in Application Rules the added application will have full access to the net.

I am sorry if this is too long.

Enjoy your stay here and have happy christmas day :slight_smile:

Valentin N

Yes, I added the exe file in application rules and selected the predefined policy of trusted application, with no results. I think there is some incompatibility between Comodo firewall and the Ubisoft Game Launcher :frowning:

have you tried to add the needed prots?

Valentin N

look here . This may help

Valentin N

Thank you again Valentin, as soon as I have a couple of hours I’ll try that. I’ll let you know.


Sorry for my long away time. Had a “little” mainboard + CPU problem :frowning:

Thanks for all your work to solve this problem. Sadly all your workarounds don’t work. I’m adding some log files from the Ubi Game Launcher in this post. Maybe someone can find out the problem. Everything looks fine to me, expect the fact, that the launcher creates a sucessful connection and directly closes it.

I don’t know how their copy protection actually works. Maybe the launcher has to do that and it’s normal. If that’s the case, the problem would be a specific line in orbitdll_launcher_log.txt.

2011-01-14 05:25:10 [2872] [DEBUG ] mg/orbitdll/ProxyConn.h (251) : SendRecv failed while waiting for class mg::protocols::SatelliteAuthRsp

That’s on the fourth line from bottom.

[attachment deleted by admin]

Just to check. Is this fixed in 5.4?

Would appreciate feedback if possible.