Turn off geekbuddy alert?

I have CIS v8.4.0.5165. Absolutely every time CIS finds a threat, it pops up that super annoying “Let GeekBuddy deal with it” message. I click on NO, and also I check the box “do not show this again”. But it seems that the check box value is ignored; every time CIS finds a threat, I get that annoying GeekBuddy popup again. How in Gods name do I remove that annoying popup?

Try this one.

I knew it. I knew it was a known issue. Just didn’t know what to search for. So, it’s COMODO’s way of promoting GB. Like Microsoft does with Win10.

But yeah, after applying the registry entry and restarting my PC, CIS stopped annoying me with the popup. Ty qmarius.

No problem. Glad that you were able to solve it.

I suspect it is related to your system as I never had such issues.