Trusteer Rapport, CIS, Windows 7 64 bit

I’ve been using Rapport for a while (as recommended by my bank) on a PC running Vista and CIS.

I’ve installed Windows 7 64 bit, CIS and Rapport, but Rapport won’t work. If I uninstall CIS, Rapport will work. Simply disabling CIS isn’t enough - Rapport still won’t work.

Any ideas?

As i don’t have this tool, i can’t test it.
If you say “Disable” CIS isn’t enough what did you disable exactly?

Firewall, Defense+, AV ?


Can you please specify the exact version of CIS you are using? Please look in Miscellaneous > About to find this.
We would also like to know the version of Rapport you are using. To find this open the Rapport console (start > programs > Trusteer Rapport > Rapport console) and look at the top-left quadrant.

We would like to invite you to contact us at to pursue this issue so we can fix it.

Thank you,
Trusteer Technical Support Team

Good work Trusteer :-TU
Can you please inform us of the versions that are compatible once fixed?


I probably should have mentioned that I have already raised this issue with Rapport (ticket #QQH-336991) but I posted because I wondered if someone in the Comodo forums might have any bright ideas.

The CIS version is 3.13.121240.574, which I downloaded from Comodo yesterday.

I can’t determine the Rapport version since the console is inaccessible but prior to installing CIS yesterday it was reporting that there are no updates available.

In my attempts to get it working have the following in a Comodo group:

C:\Program Files (x86)\Trusteer*
C:\Program Files (x86)\Trusteer\Rapport*
C:\Program Files (x86)\Trusteer\Rapport\bin\RapportLaunService64.exe
C:\Program Files (x86)\Trusteer\Rapport\bin\RapportMgmtService.exe
C:\Program Files (x86)\Trusteer\Rapport\bin\RapportService.exe

and that group has been assigned Trusted Application privileges. Plus I’ve individually given the three executables explicit permission to do just about anything under Access rights.

The RapportLaunService64 process is running. So is RapportMgmtService. But if I try to access the Rapport console I am told Rapport is not running and if I say Yes to starting Rapport it fails.

So I tried to completely disable CIS to see if Rapport would work then with a view to narrowing down the problem. I don’t use Comodo AV - just the firewall and Defense+. By disable I mean select the deactivate Defense+ option (which requires a restart) and set the firewall to disabled. Short of uninstalling I don’t think I can do much more to disable CIS. At Trusteer’s suggestion, I tried uninstalling CIS and Rapport then worked.

Note I do have Avira Antivir and Spyware Doctor installed alongside CIS, but Rapport is fine with those. It is only once CIS is installed I have problems. I have tried disabling Antivir and Spyware Doctor as well as CIS but I haven’t tried uninstalling either of those while keeping CIS to see if Rapport works then.

I have the same problem as iandom - 64bit windows 7 using Rapport happily until I installed Comodo. now the Rapport service does not start although I have “allowed” a number of challenges generated by comodo as it attempts to start. I did get an error when trying to start Rapport service “windows cannot access the specified device path or file” relating to Rapport/bin/RapportService.exe but this is not reproducible.

I reinstalled Rapport yesterday so I assume I am using the latest version lionked to by RBS. Using v3.13.125662.579 Comodo firewall.

I assume this is a problem that will impact all users of 64bit Windows 7. Many thanks for your help in addressing this.


Can you take a look under Defense + → Common Tasks → View Defense + Alerts if there are alerts regarding Trusteer Rapport? If so can you post a screenshot of it?

Hi Eric,

Thank you for the prompt reply - it is appreciated.

There is one entry - attached.

Best Wishes,


[attachment deleted by admin]

Try adding the RapportNikko.dll to the files rundll32.exe will execute.

To do so go to Defense + → Advanced → Computer Security Policy → select rundll32.exe → Edit → Access rights → push the Modify button behind Run an executable → add RapportNikko.dll to the Allowed Applications list. Now Apply and Ok your way back to the main screen.


When I checked it was already there - may explain why I haven’t had the error message again. Now I get a message saying “Please wait while starting Rapport” followed by a message saying “Could not start Rapport”. I can’t find any relevant messages in the logs.

Any other thoughts?


I was asked to participate in a remote debug session with Trusteer support but before that took place I performed a complete reinstall of Windows 7 partly to ensure I knew exactly what was on the PC but partly because of some other stability concerns. I held off both Rapport and Comodo until other software was installed. As a result, I used the PC happily for a couple of days with no problems.

On the day of the session, I installed Rapport and had no problems. I then installed CIS and had no end of problems. Firefox was bombing out, so was the Foxit reader. IE was unstable. Come the time of the session with Trusteer and getting that started was hard (three reboots to get there) and everything they tried failed.

I wound back to the morning setup using System Restore and ERUNT and then reinstalled Rapport but not Comodo. No problems since.

I’m afraid in my view the smoking gun points at Comodo on Windows 7 64 bit and with some reluctance it is going to be dropped from my armoury. This is a shame because Comodo has been great.

The only thing I can think of right now is to look at the Windows logs under Applications and see if there is a clue. The logs can be found under Control Panel → Administrative Tools → Event Viewer.

There is a conflict between Trusteer Rapport and FF Preloader (version 1.0.366.0)
I installed TR a few days ago at the behest of my bank. Since then TR has worked well in IE8, but not in FF, where it failed to work at all. I have version 3.5.6. When using FF, twice my PC restarted without warning, followed by a message about a ‘serious error’. I contacted TR about this and they have today resolved the problem online, over 1 hour 30 mins, advising the fault is a conflict with FF Preloader. I have unloaded that in HijackThis, rather than uninistall it. TR tell me they will let me know when they have reconfigured their application accordingly. BTW, they are sending me a £30 Amazon voucher for my trouble!!


Unforunately there are no error messages in the log. There are two services running Rapport Launching Sevice and Rappport Managing Service - but starting the Rapport Service itself fails.

Looks like there isn’t a simple solution. Many thanks for your help.


When you try “Deactivate D+ permanently (requires a restart)” under Defense + → Advanced → Defense + Settings does the problem persist? With iandom the problem persists.

Yes the problem persists.


Then it’s the same problem as reported. Let’s hope the devs pick up on it.

I am currently using CIS v4 beta (moderators only) but I recall there was no trial for the program. So I cannot test if things may be changed with v4 as it stands now.


Thank you very much for your help - it is greatly appreciated.


Guy’s i have contacted Trusteer Support
So we’ll see next week where this goes…

Kind Regards,

Hello Ronny,

Thank you for contacting Trusteer Technical Support.

The response was by the head of the tech support team. He will gladly contact you next week, looking forward to work together.

Ticket Details

Ticket ID: xxx
Department: General
Priority: High
Status: Customer-Pending

Guy’s i need someone with this problem and Trusteer version 912.12
If there is still someone with this version and the problem with CIS 3.13.x then we need to connect you to both parties dev’s to see if they can fix this.

So let me know if anybody is willing to help here.