Trusted Software Vendors


I recently removed Comodo & reinstalled.

Anyway, I noticed that when I ran a SupeAntiSpyware update, I was not prompted at all by Comodo. I figured SAS must be a trusted application, but I did not see it in the Trusted Software list.

And, there are two vendors defined by Comodo & all the rest are defined by “User”. Considering that I did not input all these vendors as trusted, I am confused. Any thoughts?

Also, I posted this a while ago & did not receive an answer & I was having difficulty replying to the post myself as I continued to be prompted that a reply from this IP occurred less than 1 second ago, although that is not the case. So, I thought I would post again as perhaps others were unable to reply as well.

Hi Bubster

If you’re running CIS 4, I suspect, someone else will need to confirm, that SAS’s update executable itself was already deemed “safe” by time you ran it. Probably by the automatic sandbox submission of the first couple of users that tried the SAS update.

From your other topic: Mods cannot easily see edits made to posts/topics. Use the “Report to moderator” function on each post/topic to attract our attention. The 1 second delay thing is a forum bug that we’ve never been able to identify. But, usually it can be resolved by logging in and out of the forums or even restarting your browser. It’s hard to replicate, so you might never see it again (not true for all users).

Thanks Kail,

I have Sandbox disabled on my new Comodo install but you’re saying that it was possibly deemed safe by others using SB, even though it is not in the Trusted Vendors List, correct?

Also, what about my 2nd concern?

there are two vendors defined by Comodo & all the rest are defined by "User". Considering that I did not input all these vendors as trusted, I am confused.


I’m not sure how it works when the sandbox is disabled. You’ll need to wait for someone with actual CIS 4 experience to clarify this as the answer might differ from that of CIS 3.

Same as above the really. I cannot verify what the defined by “User” signifies in the Vendors list for CIS 4. But, I do suspect that it might depend on your settings and installation details. So, you had probably post those to help the CIS 4 people that might respond.

In addition to the “Trusted Vendors List” Comodo also maintains a huge list of trusted files. These are kept internally and cannot be viewed, but I assume that the files for SuperAntiSpyware are in there.

As far as I know this is the way it’s been since V3 (when I first started using it). In my opinion, and many other people’s, if the vendor was deemed safe by Comodo then it should say it was added by Comodo. Hopefully this will be fixed in the next few updates, but I wouldn’t hold your breath. ;D

Can someone let me know if I’m wrong and there is a reason for this. Thanks.

I had this problem very often back when I used Firefox (I now use Comodo Dragon). You can either log in through another browser, if the problem continues, or if you can provide any details that you remember you can provide information to Report Comodo Forum / Web Site Issues. Another thing that worked as a work-around for me was to put in the username and password and then wait a few minutes to submit it. You could give this a try if the problem continues.