Trusted Files purge resets after leving TFL and immediately coming bck[M586][V6]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?:
    Yes, every time.
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    I open Advanced Settings - Security Settings - File Rating - Trusted Files, then select purge option. In the Comodo Pirge windows I click OK, the trusted files list gets smaller, and when I click on the purge again, the window appears that says “All entries are valid”. After I click OK or close Advanced Settings window, I can go to the trusted files list and purge it again with the same result.
  • If not obvious, what U expected to happen:
    I expect not valid files being deleted from trusted files list.
  • If a software compatibility problem have U tried the conflict FAQ?:
  • Any software except CIS/OS involved? If so - name, & exact version:
  • Any other information, eg your guess at the cause, how U tried to fix it etc:
    After CIS reinstall / OS reinstall all work fine, but only untill I delete some file that has been marked as trusted from my user folders, i.e from Desktop or Downloads. Purge works only once and after one success cleaning not valid trusted files list starts to grow. Deleting all files from the list doesn’t help.
  • Always attach - Diagnostics file, Watch Activity process list, dump if freeze/crash. (If complex - CIS logs & config, screenshots, video, zipped program - not m’ware)
    I’ve attached Diagnostics file and Watch Activity process list.

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- Exact CIS version & configuration:
COMODO Internet Security 6.2.285401.2860 (also COMODO Internet Security 6.2.282872.2847)

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
    HIPS - safe mode, Behavior Blocker - fully virtualized, Firewall - Custom Ruleset, AV - Stateful.
    I’ve also tried Default Configuration.
  • Have U made any other changes to the default config? (egs here.):
    AV and the Cloud lookup are enabled.
  • Have U updated (without uninstall) from a CIS 5?:
    [li]if so, have U tried a a clean reinstall - if not please do?:

[/li]- Have U imported a config from a previous version of CIS:
[li]if so, have U tried a standard config - if not please do:

[/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 7 x64 with all latest updates, UAC disabled, Real System, run as administrator / Windows 8 x64 with all latest updates, UAC disabled, Real System, run as administrator.

  • Other security/s’box software a) currently installed b) installed since OS:
    a) none b) none

[attachment deleted by admin]

I delete my username from screenshots. I hope it is not necessary. :slight_smile:

Okay, I cannot replicate this. When I purge the Trusted Files List (TFL), and then select OK, if I open it again and click purge it says that “All entries are valid”. By the way, I believe that if you close it by clicking the X, and then open again and purge, it may be intended behavior that the files purged from the list are put back in. However, as you said you also saw the behavior when selecting OK, this means that it is a bug.

I even tried first deleting a Microsoft file from the TFL, and then selecting OK. Then I went in and clicked purge. It said that all entries were valid. Then again, perhaps the issue was that I had first purged the list such that there were not extra files to begin with.

Does this only replicate on your machine if you had first removed a trusted file and then purged?


I have similar behavior. But when I close both Comodo Purge and Comodo Advanced Settings and re-open purge dialog - I get that problem again.

It is replicate on my machine if I delete file from HDD (i.e. during uninstall) that has been put in TFL.
This also replicate on other machine with similar settings.

I’ve also done complete reinstall of CIS and after signatures update, quick san and rebooting, I’ve delete CIS installation file from Desktop and got the same behavior.

[attachment deleted by admin]

Okay, I am not able to replicate this. However, as it continues to occur for you, even with reinstalling the OS, I will forward this to the devs.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

The devs have not been able to replicate this. Are you still experiencing this issue?

If so please export your configuration to a file and attach that file to your next post.


Yes. But I develop solution for me - I create backup of trusted.db and pending.n form “C:\Program Files\COMODO\COMODO Internet Security\database” after OS & all software installation and replace existing files with backup files after software upgrade.
After doing so I have only two invalid entries and this bug no longer bother me.

[attachment deleted by admin]

Today I’ve installed Comodo Internet Security Premium 6.3.291162.2907 Beta, then configured it for my needs and I’ve found that bug has gone. Trusted Files are now purged correctly.
I’ll also post here about Trusted Files purge function behavior after 6.3 will be released.

Please note that the Beta you are referring to has not been officially released. Thus, I would not recommend installing it on production machines.

That said, I’m glad to hear using that solves your problem. However, as I’m not sure where that CIS build came from, I will leave this post in the format verified section for now. Once CIS version 6.3 is officially released please check once again, and let me know if the problem is solved. If it is I’ll move this to Resolved.

Thank you.

The devs have not been able to replicate this issue.

Can you confirm that it is fixed for CIS version 6.3.294583.2937?

Thanks. PM sent.

wogoda has informed me that this is fixed for CIS version 6.3.294583.2937.

Thus I will update the tracker and move this to Resolved.