Trusted files bug [Issue Report]

Hello everyone,

The bug/issue:

  1. What you did: just looked up in the “Trusted files list”.
  2. What actually happened or you actually saw: 2 entries that are the same file in differente places.
  3. What you expected to happen or see: 1 entrie of the same file.
  4. How you tried to fix it & what happened: cant fix it
  5. If its an application compatibility problem have you tried the application fixes here?: –
  6. Details & exact version of any application (execpt CIS) involved with download link: Aion.bin
  7. Whether you can make the problem happen again, and if so exact steps to make it happen: –
  8. Any other information (eg your guess regarding the cause, with reasons): Take a look in the 2 screenshots: there are 2 entries that are the same in differente places… I played this game long time ago (aion.bin) and added it to the trusted files list through Defence + pop-up I chose to allow + remember. some days ago I opened the game and a pop-up of Defence + showed up about aion.bin so I allow it +remember but \i don’t know why CIS asked me again for it.

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug: trustedfilesbug1, trustedfilesbug2.
  2. Screenshots of related CIS event logs and the Defense+ Active Processes List: n/a
  3. A CIS config report or file. - attached
  4. Crash or freeze dump file: n/a

so the bug is that there are duplicate entries in th trusted files.

  1. CIS version= 5.5, AV database version= 9705 & configuration used= proactive:
  2. a) Have you updated (without uninstall) from CIS 3 or 4: No
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:
  3. a) Have you imported a config from a previous version of CIS: No
    b) if so, have U tried a standard config (without losing settings - if not please do)?:
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): Heuristics lvl manual scanner: High, cloud scanner enabled.
  5. Defense+, Sandbox, Firewall & AV security levels: D+=safemode , Sandbox=on , Firewall =safemode , AV = stateful
  6. OS version, service pack, number of bits, UAC setting, & account type: win 7 64 bit sp0. UAC =off account: admin.
  7. Other security and utility software installed: None.
  8. Virtual machine used (Please do NOT use Virtual box): None.

[attachment deleted by admin]

Please split this bug report in two separate ones; start another bug report for the av bug.

The reason you are seeing two entries is that the program must have been updated. CIS recognises files by their Hash codes. But the user interface shows file paths. That is confusing indeed.


I think u are right, it maybe the reason. however, I didn’t know that the game updater made an update… strange.

MMO’s get updated all the time.
you should get in the habit of using that “Purge” button as often as you can. it removes entries that don’t actually exist on your PC anymore.

Thank you for your Issue report.

Moved to verified.

Thank you