Trusted file sandboxed


is it normal for a trusted file to be sandboxed.


Sorry for the double posting, tried to delete it but could not.

[attachment deleted by admin]

It certainly happens that regular applications get sandboxed. The file is apparently not on the whits list or the vendor is neither in the list of Trusted Software Vendors.

When you know the file is legit and is coming from a reputable source go to Unrecognised Files, select it and move it Trusted Files. Next time the program gets run it should not be sandboxed anymore. Sometimes a reboot can be required.

Post back if it keeps on getting sandboxed after being moved to Trusted Files.

This happens to me also with a file named CtHelper.exe, which is part of the Creative Audigy device driver. The file is in trusted files list, online lookup says its a safe file, but it still gets sandboxed every time i start or restart my computer.

It’s the latest driver for audigy cards, can be downloaded from here

PC specs: AMD Athlon x2 4000+ 64 bit, 2Gb DDR2, 250gb SATA hdd, gainward 8600gt, windows 7 x64 fully updated

Comodo Internet Security 2011 settings: proactive configuration, AV = stateful, firewall = safe mode, D+ = safe mode, sandbox enabled

[attachment deleted by admin]

Read the introduction to the v5 sandbox, see my signature, and try the tips given there.


I am also having same problem with cthelper.exe from creative. I have followed instructions from v.5 sandbox to no avail. It appears that no matter what you do, the cthelper.exe is always run in sandbox even if you change trust level etc.


A bit hidden in the Introduction to the sandbox is this post:

At hawkster and Piedone. Did you try the above suggestions?

Yep, tried 'em all, even added a defense+ rule, as trusted application then i’ve tried it as installer/updater, yet still gets sandboxed after a restart.
Strange thing is, it doesn’t show up in the trusted files list, and when i want to add it manually, it says it’s already a trusted file. Well, this file getting sandboxed doesn’t do any harm after all, its just strange :slight_smile:

This problem is reduced in frequecy from 4.0 but evidently we have not completely lost it, as the devs hoped.

Meanwhile, if you don’t mind visiting the 4.0 FAQ, and interpreting bit (eg Safe 4.0 = Trusted 5.0) you will find many more techniques here. I’ll update these for version 5 as I work out what is happening.

After finding out which if any fix it please consider making a bug report using the sandard format in the bugs forum here. We are actively tracking bugs submmited using the standard format now. This will also help me update the help.

Best wishes


[Edit: Just checked the bugs/issue tracking system and this exact problem, cthelper is already reported and linked to report #171]

Great then, thanks for the heads up.