"Trusted Applications" that actually believes me

When I designate an app a “Trusted Application” I expect Comodo to understand that I trust the application. Not, that I trust the application to do that one thing that Comodo is asking me about. Right now it will ask me about apps that access the registry. Then it will ask again when the app creates files. Then again when the app tries to access the internet. All of those things should be monitored, and if I don’t designate an app as trusted, I want to see all of those alerts/queries.

However, when I designate an application as being trusted, that should be the last I ever hear about that application, until it gets updated or changed.

At the very least, there should be a way to set the behaviour so that people like me, who only set apps as trusted that I really do trust, can make Comodo just a little bit quieter.

IMHO asking permission when trusted application tries to connect internet should be normal as firewall should monitor ‘outside connections’ as per user’s wishes in Custom Policy Mode. Have you tested it in safe mode? In safe mode you may not get an alert.

In my case trusted applications are given full permissions (including registry changes) But when other programs try to inject something, I do get alerts (and I feel it is rightly so).

Any way you can check the configuration at

CIS>Defense+>Advanced>doublick on Application Name

If it is shown as ‘custom’ doublick clik on access rights and ensure that everything except run an executable is shown as ‘allowed’. AFAIK, in such a case you will not get any alert.

I always run in safe mode. I only get the alert once. But I get three alerts for any new app I add. And my point is that when I say an app is trusted. In that one condition, when I have specifically said “I trust this application. This application can do whatever it wants to because I trust it.” Comodo still checks three times, and I need to designate that it is indeed a trusted application three times.

It becomes a pain with games and when I’m trying to recommend Comodo to friends and family who want a solution that isn’t too much of a pest. In the first case, it will often freeze up the computer with the screen black because Comodo is waiting for an input that I’ve already given once, but now needs again. In the second case, I’m trying to encourage people to use Comodo because, for the most part, I love it, and they universally complain about the multiple alerts when there should only be one.

I am firmly of the opinion that if I designate an app “trusted” that means it’s “trusted”. It doesn’t mean, trusted on Tuesdays. It doesn’t mean trusted to have .exe on the end of the file name. It means I trust it and it can do what it wants with my computer. Hence the moniker “Trusted”.

Okay, have you checked your configurations at for that application in defence+ rules?

CIS>Defense+>Advanced>doublick on Application Name

In the access rights is everything, except run ‘an executable’ is shown as ‘allowed’?

I am having the same issue, but it seems to be with just one application (that has a launcher). I have gone through the “Allow request” and checked the box for “Remember my answer.” I have done this many times, and I’m sure I will do it more. I had once solved the issue by going into Defense+ and setting up a trusted vendor using the running process as the signed source. This solved the problem once before, but not now.

I am also in safe mode.

I am not writing this from the affected computer, so I am not sure which version is running. I had to reinstall my system over the weekend and downloaded Comodo again from download.com. Maybe I should check that I have the most current version. But to the other person who started this thread, trying setting up the Trusted Software Vendor under the Defense+ section.