TrustConnect account broken - please help

For about two weeks TrustConnect VPN service has been broken and an AUTH_FAILED error is given when trying to connect. Everything worked fine with exactly the same settings, etc for over a year previously. I have a paid service (Unlimited, paid 100 USD!) valid for several more months.

I have tried connecting from over 5 computers with separate OpenVPN/Comodo’s custom OpenVPN software with exactly the same problem. These computers are on different networks so it’s not a network issue. Other TrustConnect accounts (I have recommended the service to several friends) work on the same computer set ups.

I have tried changing the service password several times (from Comodo Account Management | Login or Create a new Account) and still the same problem persists.

I have opened a support ticket and that has not helped either.

The only conclusion I can come to is that something is broken on Comodo’s end. As a last resort I am posting this with the hope that the problem will finally get looked at properly and be resolved. Please PM me for my TrustConnect username.

Thank you.

Hello east77;

I’m sorry that you are having difficulties with TrustConnect;
It seems like you are having problems “Signing On” TrustConnect; (Logging In)

If you wish; you can start a Free 60 Trial With GeekBuddy; and I’m sure they can solve this much quick than I

I’m assuming you have read the FAQ on Trust Connect’s Website…
If so; Then I would also look at the password and the username (In the Management Area) and copy and paste; Does this work?


Hi Jacob, thanks for the reply.

The service username and password is being entered correctly.

I have a fair bit of experience with OpenVPN (both client and server side) so I know what I’m doing. As mentioned in the first post, I have tried connecting from multiple computers (both Windows and Linux) with the same error.

Just to be safe, don’t use copy/past, I ran in to issues with this.
I always past to a command-box first and then copy/past it in to the app.

How much time did you give the system to sync the changed password, and can you PM me a full logon log?

Hi Ronny, sent you a PM with logs.

I have given up to several days for password syncing, so that’s not likely to be the problem.

Can you provide me with the TicketID and the account you used to report it with?

Hi Ronny, sent a PM with the info.

Our TC account is still not working. Is it possible for an account to automatically get disabled by Comodo even if the account management site says the service is still enabled? How hard is it to re-enable an account?

This is crazy, my account is still broken. It seems Comodo have serious trouble fixing things if something goes wrong on their end. I guess that’s a drawback in dealing with large companies.

I thought posting here would help but so far it hasn’t.

I even set up a Windows computer (this TC account is mainly used on a Linux computer) so their support could log in to “test” my set up. I had to convince their support personnel that their is nothing wrong with my set up by opening a trial account and demonstrating it working perfectly.

I would have canceled the account but I have prepaid until October 2011 and THEY DON’T GIVE REFUNDS according to their terms of service. Let this be a warning to anyone before signing up for a year.

To their credit, the service worked fine the first year. Funny thing is I paid half the amount (50 USD) for that first year. Then the price doubled and a couple months later it stop working!

I will update this thread with the outcome of all this.