trounle with default serach

I recently downloaded comodo and am trying to change my default search engine, I went to setting’s and changed it …it even shows as startpage as my default but whenever I search through the top address bar it searches yahoo >:-D

I hate yahoo and even deleted it as a search engine under settings but it wont go away, any ideas?

I don’t observe this problem. ???
Try - to Clear history.
Cache, etc.
As look at the page by default


Have you tried adding the search engine through Startpage’s “add to chrome functionality”? There is such a button on and it automatically adds the search engine to Dragon’s settings.