Trouble updating to 3.9

i’m running xp x64 sp2 with comodo 3.8 something (i have no idea which one, see image)

anyway my problems started this morning when the cis asked me to update - i clicked ok and it started updating - after that i rebooted and after a minute or so it said there was another update so i updated again and rebooted. since that last reboot the whole system hangs up a minute or so after i logged into windows (and its loaded) - it just freezes and does nothing - so i then tried to uninstall it completely and do a fresh install (downloaded the newest version 3.9something24.507 on my other computer) in save mode
it keeps freezing the whole machine - had to manually remove everything comodo related from the hdd and registry because the uninstaller was missing after the installation for some weird reason
i then tried to install an older version i still had on my hdd somewhere (3.8.65951.477) and that just says something doesn’t work - when i run the diagnostics tool it says nothing’s wrong but it still won’t work - after 3 more attempts of installing the newest one i gave up and tried to install another firewall and found out that my network interfaces won’t work anymore (in the properties-dialog it didn’t show the name of the adapter and only showed the ms networking protocol thing - no tcp/ip or any other protocols)
now i used the windows system restore thing and everything works again - but the unknown version (see screenshot) of cis looks weird because it doesn’t have a theme anymore (can’t set one either)

i hope someone is able to help me soon :confused:

Exactly the same thing happened to me running the firewall only. I downloaded the update last night and when I rebooted this morning the whole thing froze. Eventually I got system restore to work which fixed the issue. I then tried to install the update by using the latest full installer CIS_Setup_3.9.76924.507_XP_Vista_x32, which didn’t even get past the setup screen before it froze everything again, very annoying. System restore again fixed it.

Same thing happened when I uninstalled it and tried to install the older CIS_Setup_3.8.65951.477_XP_Vista_x32. Another system restore!

I also lost the theme and Comodo now has a gray background. I`m not touching any more Comodo updates until this is fixed.

Comodo firewall has been running fine for about a year now since I first installed it as a firewall only program before it was CIS and I’ve been impressed with it so far.

Two hours lost this morning because of this! >:(

Running WinXP 32 bit SP3, and no other security products apart from Avast AV.