Trouble updating Comodo Firewall Pro

Hi folks!

Yesterday I updated from CFP 3.0.14 to 3.0.16 and got nothing but trouble with this.
First of all, I tried the build-in updating functionallity. First, i run well, but after having downloaded 56%, the running instance of CFP crashed. However, the update was downloaded completley und startet installing, but installation failed though “cfp.exe could not be replaced”.
Well that might be my fault, since I was logged in as non-admin ;D

Then, I switched to admin user and downloaded the release from Comodo website and run the installer. And then the same happeden as when I was updatein 3.0.13 to 3.0.14:
Installer first forced me to uninstall the previous version. Dear Comodo-folks: why?! Current update technologies are able to UPDATE installed software!
Well, I uninstalled, rebooted and installed the new version. And then, again, all my settings were lost! Just like after the update from 3.0.13 to 3.0.14! hrmpf
I troublesome restored all my settings and now CFP works fine. (R)
But why an update does not UPDATE, but re-install?? And why the settings are lost?
I love CFP, but updating is a torture…

BTW: Exporting configuration with non-admin rights fails with the message: “Unable to export the configuration. Please make sure you have enough rights for the path”, even if you HAVE rights for the path (e.g. “my documents”). The file also is being created, but it remains empty (0 byte).

Please make a better handeling for users logged in as non-admins…

In my view, users without Administrator privileges should be either prohibited or severely restricted from installing or modifying software such as a firewall or anti-virus.

A lot of your issues probably could have been averted had you signed in with Administrator privileges in the very beginning. And yes, I understand the reasoning for using a system as a non-Administrator; it offers yet another layer of security. A complete uninstallation of your previous version of CFP would have been advisable since you were apparently updating past an intermediate version of the program.

The latest versions of CPF (v.277 and v.295) are now updating with few or no issues on most users’ systems. The uninstaller IS getting better, but it is not perfect.

In any event, we’re glad your current installation is working, despite the problems you encountered.

Yesterday I updated to (now I did it all in admin mode) … and it did it again! All my settings are gone!
I have foreseen that comming, so before installing the new version, I exportet my configuration.
Oh, how easy it would be if I just could import that file… CFP keeps sayin that the configuration has been imported successfully, but this is just a lie. Nothing happens to the current config.
So how do I get my file importetd? PLZ help…

Importing previous configuration settings seems to be a serious problem with the latest update (v.304).

While this might not be a major issue for many users, it certainly will be for those whose systems are complex and require a large set of custom rules.

The v.304 update failed on my IBM T43, much to my dismay after it updated flawlessly to v.295 from v.277 via CFP’s internal updater.

Looks like “one step forward, two steps backward” with this latest release. (:AGY)

swearing The same swearing every time swearing
So I am to restore all my swearing setting by myself?!

Guys, I love CFP, but it can’t be, that with every update my configuraion is beeing blown away! Such a critical application as a Firewall must stay up-to-date! But I can’t have this wohle swearing every time!

My system is not complex. It’s an ordinary Windows XP Home with SP2. No other Firewall oder Adware is installed. Just my antivirus ( My CFP configuration isn’t that copmlex, too. Some network zones, some port sets, some custom rules…

swearing … Now I’m feeling better…