Trouble sending e-mail with Pegasus 4.4 & Comodo

Hi there,

Newbie here!

Every time I try to send an e-mail with Pegasus 4.4, I get a “6: socket timeout” message from within the software. If I try 3-4 times, the e-mail usually goes out. However, if I adjust Comodo’s Security Level to “Allow All”, the e-mails get sent the first time, every time.

How do I set Comodo so that I don’t have to change the Security Level every time I want to send e-mails?



Welcome to the forums, Paul_W

To find out where/what the problem is, can you post what is in your CFP log. Click Activity → Logs, and make a screenshot to post here (alt-prntscrn to copy the window to the Windows clipboard, then cntl-v into Paint (or some like program), save as a file, and then attach that file here with your posting)

Also, can you post a screnshot of your CFP network monitor rules? Click Security → Network Monitor, and same process for the screenshot.


Here they are.

[attachment deleted by admin]

Thank you. Looks like you’re running the default installed network rules. That shouldn’t cause any problem. And the CFP log isn’t showing anything relevant to an email problem.

Let’s check a Pegasus Mail setting. Open Pegasus Mail, and click Tools → Options. Then in the General Settings, Advanced Settings, the “Load Windows Internet Services (Wsock32.dll)” should be set for “demand only”. That will let Pegasus Mail determine what kind of TCP/IP stack support it needs. On WinXP machines, it’s usually the default system stuff.

That’s how Pegasus was configured. I didn’t change anything. ???

Hmm. Okay, let’s see if Pegasus Mail can tell us a little bit more about what is going on.

Pegasus Mail has a logging option (Tools → Internet Options, on the bottom of the General tab). Check the box to enable logging, and click OK. The log file will be created in the folder that holds your mail setting and will have the name TCP0001.WPM (where the 0001 is a counter for multiple log files). If there are connection problems, there should be details in the log. If you’re not sure about how to read the log, you can post it here, with this WARNING:

Pegasus Mail log contains your connection password and authentication methods. If you post your log here, I strongly advise you to edit the log first, and remove all password information. You may also want to edit any email addresses that are in the log, as the postings in this forum are scanned by spammers looking for email addresses.

Pegasus Mail will create one log file for each mail operation, so you will get multiple log files.

If there is some kind of problem with the servers you’re connecting to, it should be in the logs. If not, then the next step will be to check your Pegasus Mail settings. But, let’s check the logs first.

The entire log is as follows:

— Sun, 20 Jul 2008 12:31:25 —
Connect to ‘’ port 25, timeout 15.
12:31:40.203 6: Socket timeout.

Believe it or not, that is actually helpful.

Checking from my machine, a connection to shows that the mail server there is refusing connections. The problem is with that server, and not your machine. Either they are in the process, or have already, of changing their servers, or their firewall (and not yours) is messed up. You’ll need to contact them to find out what’s going on. You may need new server connection details, if they are making changes in their setup.

Checking, it seems to be using for services. I don’t know if this is a recent change or not. It looks like email service is available thru the web at I did check for some kind of web help, but I didn’t find anything useful, so I was probably looking in the wrong places.

I spent a long time online with Sympatico yesterday and they had me use my Sympatico hotmail account to send test e-mails, which caused no issues. They also said that they only support Microsoft e-mail clients! (:AGY)

The support guy gave me all of the appropriate settings, which I verified in Pegasus, but still no luck. He gave me 3 alternate smtp settings to use and none of them solved the Pegasus issues…

This is really frustrating.


My testing was with telnet, trying to contact their mail server directly. It failed, which leads me to conclude their mail server is being shielded by an overly aggressive firewall. It’s an easy enough test:

From a command prompt, tr this:

telnet 25

If it connects, then you should get a line that starts with a timestamp and is a “hello” message. Just answer “quit” to close the connection.

If the connection just simply times out, which is what my testing encountered, then in simple network terms “you can’t get there from here”, with any mail client. It’s a network routing/firewall issue, on their side.

I just did a different test, with a network traceroute. My results are

Tracing route to []
over a maximum of 30 hops:

1 <1 ms <1 ms <1 ms
2 * * * Request timed out.
3 2 ms 1 ms 1 ms – blanked –
4 35 ms 35 ms 35 ms – blanked –
5 35 ms 35 ms 35 ms – blanked –
6 35 ms 35 ms 36 ms – blanked –
7 38 ms 39 ms 36 ms – blanked –
8 63 ms 65 ms 64 ms
9 63 ms 63 ms 64 ms
10 75 ms 75 ms 73 ms
11 75 ms 74 ms 74 ms
12 79 ms 264 ms 74 ms
13 * * * Request timed out.
14 * * * Request timed out.
15 * * * Request timed out.

From what I can tell, is a router in Toronto. The problem is with that router, or the network behind it, or the related firewalls. A tracert (also run from a command prompt as “tracert”) from your machine may show different IP addresses, as you may have very different router paths to get to the same place.