Tried to upgrade to CIS 5.X

I tried to upgrade to CIS 4.x the other day. After downloading it, I reset my computer to a basic computer (I have Norton Ghost images at stragetic points). I installed CIS 4.X (corrected from original post), and got something I never have got with CIS 3.X before. The message, when I clicked cancel on a program trying to start was “Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access the item.” I even got this when I told it to block the request.

If I don’t want a program to start, and I click cancel or block it; this message is really, really annoying. So, I restored my computer to the CIS 3.X version using ghost. I want to upgrade to 4.X, but don’t want this flipping message. How to I prevent it from coming up?


It looks like Windows Boots up, tries to start an application but Comodo blocks access to it.

Perhaps a better way that might avoid this would be to use;
Run-> msconfig
or MAYBE… run-> services.msc
and disable the start up of that application through windows.

If I don’t understand you correctly may you please post a screen shot of-- Comodo → Defense+ → Events.

Hope this helps…

An example would be to start solitaire, then CIS asks about allowing it or not, and if you press cancel, the message is given (in 4.x). I can do the same thing in 3.X and I don’t get it.

I had issues logging in after logging out. The solution for me was to add the Windows folder to ‘My Own Safe Files’.
I found this seems to work for my games also (added their folder also).

The issue is that this message NEVER came up in 3.X. If I would start a program that I just wrote (for example), then cancel it trying to run, I wouldn’t get this message, but under 4.X it would.

The cause of the problem is the Maximum Proactive Defense. If you use the Optimum Proactive Defense, you won’t get it.

Ok, I was wrong here. It still does it. But, something interesting happened here.

I was testing CIS5 again, and I intentionally blocked a program (block this request and remember it). However, I went into CIS5 to unblock it, and I can’t find where it is blocked. What am I missing? I have proactive defense active.

I also did basically what “” said (but for my program), and I still couldn’t find it.

I believe if you manually block a program it can be found in Defense+ / Common Tasks / My Blocked Files.

May be you blocked Explorer from starting the program.

Look up the rule for Explorer → select and edit it → Access rights → now push the button behind Run and executable and look under the Blocked Applications tab → remove the program there and Apply and Ok your way back to the main screen.

Did that do the trick for you?