"Treat as blocked application" has to be selected twice


using Win10/x64, Firewall

Example: I open Thunderbird. I’ve already defined firewall rules for IMAP/SMTP, but Thunderbird sometimes uses http(s) additionally. In this case, the popup message appears, I select “Treat as blocked application” without checking the save checkbox. I expect that Thunderbird is now blocked as long as the process lives. What actually happens is that the popup message appears again, and I have to confirm it. The popup is displayed always twice, not more, not less.

Only one Thunderbird process is running. Thunderbird is an example. It also happens with other applications.

I’ve discussed this issue already almost two years ago, but it still exists. It’s a new installation meanwhile. So, is this behavior “by design”?


Depends on what your ‘alert frequency level’ is set to in firewall settings.

General Firewall Settings, PC Firewall, Firewall Protection | Internet Security for an explanation.

I tried a few times with qbittorrent with firewall set to custom ruleset mode, some times it would not show a second alert, other times another alert would appear right after choosing any block action. My guess is that the alert queue doesn’t always clear out after choosing block without using remember my answer selection.

Alert frequency= Very High. Though it shouldn’t ask again if already said “treat as blocked”.

Right. IMO it should be cleared though.