tray menus do not work

Dear all,

I have installed the latest Comodo Hungarian version for a friend, the latest downloadable. It does work but somehow the tray icon is unusable: right-clicking it brings up the menu, hovering over a menu brings the submenu, but selecting any item in the submenu (or for exampe just Open from the main tray menu) just freezes the whole thingy in the bottom right corner.
The menus stay there forever but nothing happens.
The only thing that works is launching the comodo panel from the Start menu programs. This comes slow but it is working - I can make changes.
Here I am however unable to query the version, and cannot for example disable Defense or anything.

Is this a problem with the language version or with the PC?

Your advice is much appreciated,

Oh, and when the menu gets stuck, if I right-click the icon again, it goes away, but leaves a placeholder. Meaning the part of the browser for example that was in the background has an empty square there with the background color.

On what OS are you?

Sorry, I should have posted that. It is a Windows Xp SP3.
Today we had a crash as well and emailed the dump zip to just 3 minutes ago.

The machine is 3 years old and was never a space rocket but it does fairly well. We also have Avast 5 on it which works fine, the user generally just uses Firefox and Live Messenger, not much else is going on on the PC. Windows firewall is turned off and windows updates are set to automatic.

Many thanks for any hints…

I assume you are using the latest , being v5. Is that correct? Look under More -->About.

What happens when you switch the user interface to English (provided by Comodo)? You will have to close the client; close it from the systray (in the right corner of your Windows screen) and start it again. Does the same thing happen?

I cannot quit the application from the system tray. In fact I cannot do anything in the system tray, that’s what the whole problem is about…

It’s like this. For the version part, I went to Start menu programs and tried to launc the panel - as I can pretty much forget the system tray as mentioned.

It got me this :

and then this does not react on anyting, can’t switch tabs or anything

after waiting for like 2 minutes and clicking everywhere in it I tried right clicking on the tray icon again, which miraculously got me this:

but it did not get me any systray menus,

But I still cannot click anywhere in this box and then when I want to close it and click the x in the corner, it just keeps sitting there for another 30 seconds then suddenly closes.

So I am unable to read the version but I know I downloaded it from the Comodo website like 3 days ago.

Do you use programs like Windows Blinds to change the way Windows looks. That has been reported to interfere by some users with previous versions.

No, absolutely not. It has the typical blue-green windows skin, Windows XP style. I really dont know what is it I should be looking at. Could it have a problem with Avast?