Trauncated entries in Defense+ Computer Security Policy [Issue Report]

EDIT: the problem described below just occurred running a simple script, while CIS has already been running for hours, and nothing to do with Windows startup.

Sorry to be putting this on you. If I’m alone in having this problem, I can live with it, but it is strange.

Before you read the actual report, please note:

I’ve been using the technique shown here for quite some time, with nothing strange on x32. The anomalies reported here started only with a new x64 installation.
Because I sometimes wish to start my system without security, I removed the CIS entry from HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run. Instead, I run a script (Security Activate.vbs) at statup which initiates CmdAgent and cfp.exe. The Security Activate script invokes Security Check.vbs, just to ensure that all components that should be running, are.

The truncation reported here does NOT occur when running the scripts directly (i.e. after system & CIS are up). Also, I tried manually replacing the incomplete entries with the full, correct name ones, but the truncated ones reappear.

Finally, I’d previously also seen this in the Trusted File list, but not recently, and I am unable to reproduce it there.

The bug/issue

  1. What you did: Run scripts at system startup, to initiate CIS
  2. What actually happened or you actually saw: CIS starts appropriately after responding to Alerts for Security Activate and Security Check. However, Computer Security Policy has entries for “\Scripts\Security Activate.vbs” and “\Scripts\Security Check.vbs”. Note missing drive letter and colon.
  3. What you expected to happen or see: Entries in the Computer Security Policy in the form of D:\Security…
  4. How you tried to fix it & what happened: Tried to replace the truncated entries with complete ones; runcated ones reappear.
  5. If its an application compatibility problem have you tried the application fixes here?: N/A
  6. Details & exact version of any application (execpt CIS) involved with download link: N/A
  7. Whether you can make the problem happen again, and if so exact steps to make it happen: Remove all references to my scripts from Computer Security Policy and restart system.
  8. Any other information (eg your guess regarding the cause, with reasons): Nothing beyond my opening comments.

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug: Attachment 3
  2. Screenshots of related CIS event logs and the Defense+ Active Processes List: Attachments 1 & 2
  3. A CIS config report or file.
  4. Crash or freeze dump file:

Your set-up

  1. CIS version, AV database version & configuration used: 5.3.181415.1237
  2. a) Have you updated (without uninstall) from CIS 3 or 4: No (fresh install on new x64 system)
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:
  3. a) Have you imported a config from a previous version of CIS: No (but it was tempting to do so)
    b) if so, have U tried a standard config (without losing settings - if not please do)?:
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): Not that I recall
  5. Defense+, Sandbox, Firewall & AV security levels: D+= SAFE, Sandbox=ENABLED , Firewall = SAFE MODE, AV =Stateful
  6. OS version, service pack, number of bits, UAC setting, & account type: Win7, SP1, x64; UAC OFF; User account as Administrator
  7. Other security and utility software installed: None
  8. Virtual machine used (Please do NOT use Virtual box): No

[attachment deleted by admin]

We would very much appreciate it if you would edit your first post to create an issue report in line with the bug forum guidelines and format here. You can copy and paste the format from this topic.

To understand the reasons why we ask you to follow these guidelines please see below.

WHY WE ASK YOU TO FOLLOW THESE GUIDELINES
Bugs/issues can be impossible or very time consuming to fix if developers don’t have enough information to reproduce them. Since CIS is free, development time is limited. So if you want your issue fixed, please use the format below to describe it.

To avoid clutter, issues not described in the format below your post will not be moved to the ‘moderator verified’ issues topic. This means that the developers may not look at it.

Best wishes and many thanks in anticipation

Dennis

My apologies :-[. Done, to your satisfaction, I hope :-\

Just in case somebody is actually looking at this: it appears that the truncation occurs only when the script is invoked via a “3rd party”, e.g. a launcher. There is no truncation if the script is invoked directly from Windows Explorer.

Thank you for your Issue report.

Moved to verified.

Thank you

Dennis

More truncation, and nothing to do with launcher shortcuts this time ???

[attachment deleted by admin]