Translate into English changes nothing

I have tried several times recently to translate web pages from German into English without success. I right-click the screen on my Windows 8 PC; a window appears that includes “Translate to English”; it is greyed out on some occasions, inexplicably, but, if not, I select it; I am informed the page has been translated but it has not.
I have visited Settings>Show advanced settings>Languages>Language and input settings… A web page indicates the following option should be present in Languages: ‘In the “Languages” section, check or uncheck the “Offer to translate pages that aren’t in a language you read” checkbox…’. It is not. I have ‘English (United States)’, ‘English’ and ‘German’ loaded in the window of Language and input settings…
I apologise if I am in the wrong section for this topic.

Hi Bob Hawkins,
I can reproduce the issue.
I actually think it is a bug that the option is still available with the right click menu.
As far as I know the inbuilt translator has been removed (From CD and Chromodo) and what we are seeing is remnants of the inbuilt translator that once was available.
I will check with the Developers if my thoughts above are correct or not.

I use the following extension.

Kind regards.

My wife says, “Three cheers for captainsticks!”
You have helped me again. I thank you once more.

You are welcome.
Happy wife, happy life. :wink: