Traffic Animation Stopped Working

A few days ago, after an uneventful boot, my CIS tray icon showed an orange flame on the left edge, and traffic animation was absent. I’m using the most current version of CIS for Windows on an XP (SP-3) PC machine. I checked settings and the traffic animation choice was checked. I cycled that choice without effect. Diagnostics reports no problem. Checking for an updated version shows I have the most current one. In all other respects, CIS seems to be working properly. How can I restore traffic animation to the tray icon and why does it persistently show the orange flames on the left side when previously it showed only a “clean” shield?

The icon with the orange ususally indicates a program update present. What version of CIS are you using? The latest version is 3.13.126709.581.

When not using the latest use the program updater under Miscellaneous → Check for updates.

I am also having the same issue as first poster. Everything was ok but the issue started when i updated to the latest version and restarted. The one EricJH is mentioning. Traffic arrows dont appear anymore, and comodo tray icon has changed to a little smaller shield and some flames on the back.

I really like those traffic arrows :(, is there a problem with me or with the latest version?

Ok updating my reply, i restarted one more time my computer and it got fixed… no idea why it did that…

In response to Reply #1 (Eric JH - Moderator), I AM using the most current version (the version you cite) as I noted in my original post. You also suggested that I manually check for an update via the Miscellaneous tab and Check for Updates utility. However, as I noted in my original post, I did that too. I’m sorry if the following sentences suggested something else: “I’m using the most current version of CIS for Windows on an XP (SP-3) PC machine. … Checking for an updated version shows I have the most current one.”

To provide additional information, I installed this version via the CIS update engine from the previous version and the current version seemed to work normally for awhile after the update. No, I did not install anything new or otherwise change my PC’s configuration at the time the problem started.

Next idea?

The reason I specifically ask to state your version number is that download page of CIS still provides the before last version (.579). Part of the version numbers reported in topics are .579.

Asking you to do a clean install may be too much to ask for such a small problem.

In case you are willing to do so start with exporting your active configuration from Miscellaneous → Manage My Configurations. Store it in a folder that is not part of the CIS installation folder. When using the AV also back up the bases.cav from the the scanners folder (this way you don’t have to do the big download).

Now uninstall CIS ,reboot and run this clean up tool. Now you can install CIS again.

Click on the CIS icon on the desktop and import your old configuration. Also see if you can copy the bases.cav to the scanners folder. When that is not possible copy the bases.cav in Safe Mode.

Now reboot.

Thanks for the detailed instructions for a clean uninstall - reinstall. You’re right, it really is too much for such a relatively minor malfunction. I might just wait for the next version and see if installing that one over .581 resolves the problem.

While waiting for further advice I thoroughly searched the forum archives and found a previous suggestion (that worked for that person) for what sounded like the same malfunction. It was to run the Comodo System Cleanup tool. Do you have any opinion on that one? I’m really hesitant to do any registry editing even with a tool that seems to have so many safeguards built-in.

CSC can be used safely. But as a safe guard when doing stuff with the registry you can make a system restore point.

I’ve found a fix for the problem (which I have to apply about 90% of the time after a shut down and fresh boot) that has worked every time. If I exit CIS (right click on the tray icon and left click on “exit”), and then re-open CIS by selecting “COMODO Internet Security” from within my list of programs in my Start menu, the program re-starts with a normal, fully functional shield icon that shows animation with incoming and outgoing traffic. Of course I always pull the plug on the connection between my PC and my DSL modem before exiting, so I am not left unprotected during the shut down / start up interval.

Perhaps CIS is not initially starting properly because of what else has or has not already loaded in the boot up sequence? The anomaly is puzzling, because I installed nothing new prior to the time the problem first appeared that should have affected the boot up sequence. Perhaps COMODO changed the program code to cause it to start either earlier or later in the boot sequence than it used to in earlier versions?