TortoiseSVN incompatibility

I use TortoiseSVN for Subversion source control over the Internet. When I attempt to do an Update operation via the Windows Explorer context menu, the Comodo CIS firewall will not let the connection through without completely disabling the firewall.

When I check the running processes to add a rule manually, it is not listed under running processes, even though it is clearly visible in Windows Task Manager. When I browse for the program and add a rule to treat the executable as a Trusted Application, I still cannot get out to the Internet past the firewall.

The TortoiseSVN client process is spawned as follows, according to SysInternals ProcessExplorer:

> services.exe
>> svchost.exe
>>> explorer.exe
>>>> tortoiseproc.exe

Intel Corei7 920
Win 7 x64 Enterprise
TortoiseSVN 1.6.4, Build 16808 - 64 Bit
CIS 3.11.108346.552 x64 with Firewall and Defense+ installed. Firewall - Custom Policy Mode. Defense+ disabled.
Admin Windows account, UAC disabled.

Hi Nekno,

Have you tried training mode ? maybe there is an other way of updating for context-menu ?

Also try the Firewall’s “Attack detection settings” how are they set ?

How’s your network connection setup ?

Training Mode may be the way to go as you have something strange going on configuration-wise.

I use TortoiseSVN daily. I update through an AutoIt script, but I decided to try a context menu update since you mentioned you were having trouble with that. I was able to update with no trouble.

I then decided to see if I was seeing the TortoiseSVN processes if I try to set up a rule manually and I see both the update and the cache process in my running processes list.

I’m running WinXP Pro x32 though, so your problem could be specific to Win7 x64 (which isn’t officially supported) or the 64 bit version of TortoiseSVN.

[attachment deleted by admin]

!ot! sees HeffeD using Launchy ;D nice tool :-TU

Launchy is one of those applications that once you start using it, you wonder how you ever got along without it. :slight_smile:

I don’t know what happened, but TortoiseProc.exe is regularly showing up on Comodo’s list of running processes, so something odd must have been going on with Comodo at the time. The process was clearly showing up in Process Explorer at the time, as I listed in the OP, but wasn’t showing in Comodo.

I post again if I can reproduce the issue. Thanks.

On odd occasion I’ve noticed the comodo process list looked “stale” (what I saw were processed that had been closed for some time). Usually just find the exe and that had worked and also added network allow rules for outgoing connections with the specified port (tortoise target port for example) and things generally went fine.