Русский для неюникодных символов

Здравствуйте,
у меня русский текст в некоторых программах пишется абракадаброй или вопросами. Знакомый подсказал что надо установить Русский по умолчанию для неюникодных символов. Кто знает как это сделать? Ось - Windows 7.

Спасибо

Здравствуйте. Вот статейка http://www.prosoftsystems.ru/tso/TSO_tp_how_to_change_codepage.htm

Если Windows XP, то можно попробовать твики реестра
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\CodePage]
“1250”=“c_1251.nls”
“1251”=“c_1251.nls”
“1252”=“c_1251.nls”
“1253”=“c_1251.nls”
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontSubstitutes]
“System,0”=“Arial,204”
“Fixedsys,0”=“Fixedsys,204”
“Small Fonts,0”=“Small Fonts,204”
“MS Serif,0”=“MS Serif,204”
“MS Sans Serif,0”=“MS Sans Serif,204”
“Courier,0”=“Courier New,204”
“Arial Cyr,0”=“Arial,204”
“Courier New Cyr,0”=“Courier New,204”
“Times New Roman Cyr,0”=“Times New Roman,204”
“Helv,0”=“MS Sans Serif,204”
“Tms Rmn,0”=“MS Serif,204”
“Arial,0”=“Arial,204”
“Tahoma,0”=“Tahoma,204”
Для Vista/7 возможно подойдут - не знаю.
А причем здесь продукты Comodo ?

Ой, пардон, забыл указать что Виндовоз-7. Подправил в 1-м посте.
Продукты Комодо? Вы о кефире, сметане и молоке и пр.? Никогда не пробовал. Они уж тут конечно не причём. :slight_smile:

Для вопросов не по теме (т.е. не о продуктах COMODO) есть специальная тема, которая называется оффтоп.

Неа, одной темы “оффтоп” мало. Нужен отдельный под-форум, а коли такового нет, вот и поставил сюда. Кстати, пусть сделают отдельное подразделение для оффтопов по-русски и не будет таких проблем. :slight_smile:

Спасибо за ответ. Увы, никак. Это ещё и для ХР. Есть ли другие варианты?

Получилось, пишу для тех у кого таже проблема:
Панель управления - Часы, язык и регион - Язык и региональные стандарты - Дополнительно - Изменить язык системы - Русский. Перезагрузить комп.
:slight_smile:

Вообще-то не “язык системы”, в виндах есть именно настройка для неюникодных приложений. Скриншоты на английском, но, думаю, там понятно, что и где:

[attachment deleted by admin]

Увы, эффект от настройки продержался недолго. Опять вопросы вместо неюникодных русских символов. Может кто знает что ещё можно сделать?

Настроил как в цитате и на картинке (взял с предыдущего поста):

[attachment deleted by admin]

Для Windows 7 следует применять немного другие значения, но смысл тот же - создать текстовый reg-файл следующего содержания и запустить его, затем перезагрузить компьютер:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\CodePage]
“1250”=“c_1251.nls”
“1251”=“c_1251.nls”
“1252”=“c_1251.nls”
“1253”=“c_1251.nls”
“1254”=“c_1251.nls”
“1255”=“c_1251.nls”

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontSubstitutes]
“Arial,0”=“Arial,204”
“Comic Sans MS,0”=“Comic Sans MS,204”
“Courier,0”=“Courier New,204”
“Microsoft Sans Serif,0”=“Microsoft Sans Serif,204”
“Tahoma,0”=“Tahoma,204”
“Times New Roman,0”=“Times New Roman,204”
“Verdana,0”=“Verdana,204”

Помогает в ряде случаев с капризными программами, например, абракадаброй в Your Uninstaller!

Спасибо за ответ. Написал текстовый файл как указано. Regedit выдаёт сообщение

Cannot import (этот файл): Not all data was successfully written to the registry. Some keys are open by the system or other processes.

Что можно сделать?