Topic: Removal/uninstall tool of Comodo Firewall and drivers 2015

Topic: Removal/uninstall tool of Comodo Firewall and drivers 2015

Upgrade to Windows 10 and uninstall Comodo Firewall about 2 weeks.
Tried to install the latest Version of Comodo Firewall for Windows 10 today. 08/08/2015

I got a message saying need to uninstall Comodo Firewall to upgrade the Comodo Firewall.
But I already uninstall Comodo Firewall, 2 weeks, so these have to be ghosts files/folders.
That where not uninstall with drivers ect…

And tell me the steps to complete remove Comodo Firewall from my PC?
Remember, I can not install to uninstall Comodo uninstall,because it will not let me upgrade!

Do you have removal/uninstall tool of Comodo Firewall and drivers 2015 for present.
Not 2013, but the present period,point in time.
And the steps involve so that I can completely remove.

Kind regards


I’m having a similar issue, I have no program files for any Comodo product, but I’m told i need to uninstall my antivirus before reinstalling. There is a file in my apps and features section for Comodo Antivirus, but when i try to ‘uninstall’ it i get an error that the setup wizard ends prematurely.
So I’m stuck not being able to uninstall or reinstall any product

Most Effective Way to Reinstall/Update CIS to Avoid/Fix Problems provides: this tool.

Thank you, that worked amazingly! Ran the first two items and didn’t have a single problem installing the latest antivirus afterwards

Salutations, :slight_smile:

I will sometime tomorrow on 08/15/2015. I am truly hoping will do the trick for Windows 10.

Kind regards,


Hi, I am a new member, I had the same problem to reinstall Comodo IS, kept telling me to uninstall before I could re-install but I already had, according to windows it was uninstalled and Iobit uninstaller was the same, I couldn’t see it in the list of either, I installed Ccleaner and in their tools was a program remover and again it wasn’t in the list to uninstall, but over to the right was a search box, I typed in Comodo and Chromium and Comodo IS came back in the search, from there I was able to uninstall CIS and the re-install went though without a hitch,
I hope maybe this can help some you with the same problem.