Toaster Pop-Ups

Whenever I get a pop-up and I click on my chosen option the pop-up remains until I do a forced shut-down.
Is there a fix for this. It doesn’t happen very often. But it’s more than too often. I like CFW but if this keeps up I’m heading right back to Private Firewall…in a hurry.

My set-up Win7x64, avast free 8.0.1489, MalwareBytes Pro and, Spyware Blaster.

[attachment deleted by admin]

Does this problem still happen if both Avast and MalwareBytes are disabled?

Please try disabling them, and restarting the computer, and see if the problem persists.

With all due respect I will “not” disable avast under any circumstances. I refuse to give up anti-virus protection just to chase an issue. Both avast and MBAM are whitelisted by CFW therefore there should be absolutely no conflict. I have made the proper exclusions in both avast and MBAM. This is quite obviously a CFW issue.

I understand that. I was just asking you to do that so we could try and narrow down where the problem is coming from. It’s possible that the problem could be due to interaction between CF and either Avast or Malwarebytes. In that case the problem would still lie with CF, but we would have a better idea of what’s wrong with CF.

A little history…I was using Private Firewall and it had a conflict with avast 7.0.1466 and I decided to try CFW.
Now I hear there have been conflicts between avast 8.0.xxxx and CFW v6.0 and 6.1. When the other users switched to a different firewall they experienced no conflicts. So it must be CFW.

:THNK I’m too smart for you Squeker

Here they are.

[attachment deleted by admin]

Okay what you’ve done is on you’re firewall settings you’ve untick

Do NOT show popup alerts - Configure whether or not you want to be notified when the firewall encounters a request for network access. Choosing ‘Do NOT show popup alerts’ will minimize disturbances but at some loss of user awareness. (Default = Enabled)

And you’ve ticked

Create rules for safe applications - Comodo Firewall trusts the applications if:

    The application/file is included in the Trusted Files list under File Rating Settings;

    The application is from a vendor included in the Trusted Software Vendors list under File Rating Settings;

    The application is included in the extensive and constantly updated Comodo safelist.

By default, CIS does not automatically create 'allow' rules for safe applications. This helps saving the resource usage, simplifies the rules interface by reducing the number of 'Allowed' rules in it, reduces the number of pop-up alerts and is beneficial to beginners who find difficulties in setting up the rules.

Enabling this checkbox instructs CIS to begin learning the behavior of safe applications so that it can automatically generate the 'Allow' rules. These rules are listed in the Application Rules interface. The Advanced users can edit/modify the rules as they wish (Default = Disabled).

Which means you want to take full control of the firewall popup correct means you want to control inbound & outbound traffic am I right, and are you have any further issue with the Defense+ popup problem can you handle them yes or no.

EDIT: And you’ve unticked Set new on-screen alert time out to: without a timeout popup this will halt your screen and you’re pop-up will just sit there.

Set new on-screen alert time out to: Determines how long the Firewall shows an alert for without any user intervention. By default, the timeout is set at 120 seconds. You may adjust this setting to your own preference.

I enabled the “do not show pop-ups”. But that still doesn’t explain why it froze like it did.
It isn’t the pop-ups that bothered me it was the freeze. Once a user chooses it should close. Not freeze. ???

Did you read this instruction carefully the link I gave you now because it very hard for me to explain because all the information relate to you’re problem are there.

  1. Antivirus, Firewall, Defense+ Sandbox, Internet Security Alerts | Internet Security v6.3

  2. Firewall Behavior Settings, PC Firewall, Firewall Protection | Internet Security v6.2

  3. Application Rules, Firewall Protection, Best Firewall | Internet Security v6.3

I think your having the same issue as these users here

I have posted a workaround in there.

Ronny IF a users unticked in the firewall settings

a) Do NOT show popup alerts
b) Set new on-screen alert time out

Both unticked trigger a popup halt is it possible

It isn’t that my laptop freezes, it doesn’t.
CFW pop-ups freeze. Everything else is fine.

It isn’t whether or not I have “this or that” enabled.
It’s the pop-up that freezes.

When your firewall popup before you click allow your software to outbound, did you tick “Remember my answer” before you click allow or treat as do you understand what I’m saying the popup won’t come back.

When you untick Set new on-screen alert time out the popup will just sit there at the bottom right hand corner without a timeout.

I does “not” matter what the settings are! The pop-ups freeze.

Than is a bug as Ronny said I’ve never had this problem on 8 W7 laptop computers for my client, that is very strange very strange indeed

It is strange! I have read all of the help files…nada.
I have tried the all of the default settings and tried to tweak a few…nada.

I like to have some control but, I enabled “do not show pop-up alerts” again. ???

I really like CFW alot. But if this keeps up…

[attachment deleted by admin]

Than you have no choice is to download v5.12 and make sure you turn off program update otherwise you’ll get v6.1

Comodo is going to release another version soon so sit tight on v5.12

Keep v5.12 just in case you might have to go back again

Thanks! 8)

OK, sorry you have this problem, it seems different from what Ronny describes, have you tried a complete re-install of CIS using these guidelines: here.