Titan Quest - cannot connect to other's game


I have just spend whole the day trying to find solution to my problem, but I can’t get it work myself, because I probably lack the knowledge of being able to correctly indentify and set-up whole thing :slight_smile:

So Im here in a hope someone could help…

First, what Im using:

  • WinXP Pro SP3
  • Comodo Internet Security 3.13
  • Connected via EDGE using USB Vodafone Modem
  • Titan Quest PC Game latest patch 1.30

At first I have completely deleted all the Firewall Security Policies, both Global and Local for each application, to start from clean.
Then I did “Stealth Ports Wizard” - “Block all Incoming Connections Stealth My Ports to Everyone”, which created 4 Basic Global Rules.

As expected, with this setting, my uTorrent is working as a downloader, and wont let people download from me.

Next, I have added my Titan Quest Executable to “Add New Trusted Application”.
With this setting I thought it will Allow Titan Quest all Incoming and Outgoing Connections.

So I started Titan Quest - Multiplayer - Join Internet Game. It loads list of all games, but everytime I click join, it says “Its unnable to connect to the server”. In 2 cases of out… I think… 30 attempts to connect, it worked. Every others case it was unable to connect. (It isnt related to in-game compatibility, as it only shows peoples and games with same client as I have - latest). I also tried to HOST some games myself and to my surprise I have found one guy who was able to join my game. However, I dont have idea how many people tried it too and wasnt successfull.

From what I understand, there is no offical Titan Quest server, each game is directly communicating between each of the players and the HOST (Creator of the game). I dont actually understand this technology well, so Im giving you this link to forum post by one guy with the same problem, which is using Comodo too and did some testing and conclusions. I dont understand it almost completely, so here is a link for more info:


Dont forget he got DSL modem and router, I only have my USB modem and connecting over the EDGE, and I dont have idea what impact on this issue this might have.

It doesnt seems same as problems with DC++ or uTorrent because these are using some known ports, but obivously, Titan Quest isnt. He also mentoins responds are coming over different port. As I said, I understand half of his research, because my knowledge of these things is VERY limited, so better if you check that yourself…

Oh and yes I have also tried completely turning off Comodo Internet Security (yes I was scared, but just did that to try 3 attempts to connect someone’s game). None of them was successfull.

At the end of his research he actually comes with some solution which I TOTALLY have no idea what he is talking about, and what he actually done. My technical English isnt really that great, its not my native english.

He says “I’ve resolved the problem. It was, indeed, on my end. I had to enable static port mapping on outbound NAT in my router. Doh. I’m eating crow.”

But then again, I dont have router. I have USB EDGE Vodafone modem, which is dial-up and my IP adress changes every time I connect, and with this fact, even that I was trying to search really hard, I couldnt find anything which would help.

Im playing other online games without issues, World of Warcraft, Anarchy Online, PoxNora. Problem with these is, if I understand it correctly, Im connecting to official servers, not directly connection with others users to make games, thats what I suppose is how it is working in Titan Quest “Internet Game”

Im really sorry for my English, but hope someone can understand my issue, and I hope there is someone who actually knows what might be causing this problem, because I seriosly dont.

I dont know what else to say, if I forgot anything important, let me know and I will try to give more information.

And if its at least little bit possible, try to use simplified english.

Thank you very much for your time.

Just a little update, as I have some more information:

Titan Quest is using uPNP technology. If I understand it correctly, it means using many different IPs and ports to work correctly, which seems pretty dangerous to me? There is many informations saying uPNP should be disabled (and I have it disabled in Windows yea…). Also, if Im right, its not using Titan Quest executable, but rather svchost.exe, meaning I would have to enable lots of IPs and ports to svchost.exe for this to work properly?

So this seems much more like a Windows settings problem, not Comodo Firewall.

Do you guys think it is really as dangerous as it seems to me?

To be honest I really dont want to open so many communication ways just to play one brainless relax game…

But some more info would be welcome, I only understand basics…

Thank you

I am not quite sure what is going on. But for starters can you post screenshots of your Global Rules (Advanced → Network Security Policy → Global Rules) and your firewall logs (Common Tasks → View Firewall Alerts)?

Can you tell me what ports TQ needs to have open for incoming traffic?

I’ve encountered connectivity issues with TQ when trying to set up a multiplayer game with my friends. Without reading all that above coz I’m really lazy in the morning I"ll just say if you want to set up a multiplayer with some friends always be sure to use the same version of Hamachi e.g., and the only version for Hamachi that worked with TQ is 1,0,1,5, download it from FileHippo.