Time stamp bug when extracting executable file of a archive.

A. THE BUG/ISSUE (Varies from issue to issue)
Can you reproduce the problem & if so how reliably?:
Yes, anytime.

If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1: prepare a zip file that contain a executable file(*.exe).
2: extract this zip file with winrar or winzip’s windows exporer context menu.
3: compare original & extracted executable file’s timestamp. timestamp is not preserved.

One or two sentences explaining what actually happened:
CFW intrupted archive extracting process and modified executable file’s timestamp to extracting time.
Only *.exe files are influenced. other extensions are not influenced.

One or two sentences explaining what you expected to happen:
Timestamp is preserved like normal.

If a software compatibility problem have you tried the advice to make programs work with CIS?:
No compatibility problem. All archives programs are influenced.

Any software except CIS/OS involved? If so - name, & exact version:
Winzip,Winrar and other archive programs.

Any other information, eg your guess at the cause, how you tried to fix it etc:
Timestamp is very important for file management.
so, I downgrade to my favorite Comodo Firewall v5.12.256249.2599 that have no this bug.(FYI, I never tried CFW 6,7)
I tried CFW 8.1 several days ago, and it’s great. but, sadly I found this annoying bug.
I disabled all CFW feature(auto sandbox,hips,…) except filewall but have no effect.

B. YOUR SETUP
Exact CIS version & configuration:
Comodo Firewall v8.1.0.4426. Default configuration.

Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
Default configuration.

Have you made any other changes to the default config? (egs here.):
No. I restored my windows with backup and clean installed cfw and test it with default config.

Have you updated (without uninstall) from CIS 5, 6 or 7?:
No. Clean install.
if so, have you tried a a a clean reinstall - if not please do?:
?
Have you imported a config from a previous version of CIS:
No.
if so, have you tried a standard config - if not please do:
?
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 7 SP1 32 bit. UAC disabled. Administrator account. No V.M.

Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=? b=?

P.S. I’m sorry for my bad english.

It’s a known issue. In the meanwhile, I will move this report to “Resolved” section.

Thank you.

I have the same issue but I can add some comments.

I found this Bug with FreeFileSync on my external USB Backup HDD.

  1. All files which will check by AV are affected like .exe, .bat, .dll etc.
  2. My use case is:
    Copy 10 files with .exe, .bat etc. from folder1 on desktop to folder2 via drag&drop. Sometimes (too often) all executable Files will get the actual timestamp to the “modified” attribute. This is not correct. If the modified timestamp is the same as in folder 1(OK), delete all files on folder2, adjust the clock 1h further and do it again till the problem occures.
  3. Even when only the firewall is installed, the same issue appears.

This problem is very serious for me, because my backup system is not working with wrong timestamps.