Time calibration failed

I use a program called NTPClock (version 2.10) for time calibration. However, it failed to do the job after I installed COMODO Internet Security 4.0. The program was working fine in the previous version of CIS (3.14), after I uninstall CIS 3.14 and install CIS 4.0, it keeps telling me that I have “insufficient privilege, can not adjust system time”.

What shoud I do to give it sufficient privilege? I have already set it as “Trusted”, but still not working.

Not sure about this one. Could you try to disable sandbox to see if the issue is related to a sandboxed application trying to access system functions?

Cheers

I tried to set sandbox security level to disable, but this doesn’t help. >:(

I removed it from all the trusted list and also the pending program in sandbox, etc. Then restart the computer, now it’s getting through and functional.

Still don’t understand what happened earlier…

I guess when you only disable the sandbox the actual process still runs with a limitation. You will have restart the application in order to get it to fully work.