Thunderbird ?SMTP? connection

Hello all,
once I activate COMODO firewall (either with its default profiles or mine) I cannot longer use the SMTP and send/receive emails on Thunderbird.
I added the Thunderbird as an “Allowed application” but it didn’t solve the problem. The port 587 is in the list (I also added a range of ports).
In my profile I could see a request to and no matter if I select Allowed app, or Email client, or I just allow for that specific request, it doesn’t work.
There is no other entry in logfiles.

I also disabled “Filter loopback” on 127., but no success. What should I do ?

Make sure the Windows firewall is turned off. Try to disable the firewall setting block fragmented IP traffic. Finally, you might need to create a global rule to allow incoming connections, you can temporary use the stealth ports firewall task and select alert incoming connections.

“Block fragmented traffic”, disabled → no connection
“Global rule with source-any, destination-any, source Port-any, destination Port-any” → no connection
“Stealth ports-Alert Incoming Connection” → no connection.

The other connections (i.e., browser, radio, network) are fine.

Go to Firewall → Application rules, find Thunderbird and select Treat as → Email Client.

By the way, it could be a problem with your email provider, sometimes they change the SMTP settings.

Already set as Email Client, or Allowed app, or set manually for each port/IP; I’ve deleted this rule several times. I also enabled/disabled “do not show popup” for “allow requests”, disabled “loopback traffic”, disabled Windows firewall, “Alert Incoming connections” on stealth ports.
There are only two calls when I start Thunderbird: one is for 127.0.01:50705 and another one to
When I disable the firewall completely, the client connects properly.

Its weird that you can’t get it to work, I tried myself and have no problems using thunderbird to access my e-mail account, I didn’t need to set any rules. What OS are you using and do you have any other security software running?

On other network and other computer, Thunderbird works properly with the same settings (so it has to do with this specific computer and network; I’ve already reinstalled 2 times COMODO on this unit and it didn’t solve the problem).
Also, on this computer I have a local email address and two Gmails (without the passwords saved); once the firewall is up and I start Thunderbird, there is no request for entering the passwords.

Do a reputation check, and analyze what it says!

Via translator


Sorry, but what to check ? …and what translator ?

See in the Ratting Scan if Thunderbird is “trusted”!

I’m using the translator to post! I’m in Brazil!

I checked, and it is already trusted (and so the vendor, Mozilla).

Add to allowed app. doesn’t solve this issue either:

It was a try! Am sorry!


Don’t worry; there is a reason why COMODO blocks the connection, but I can’t figure out why (and I use this firewall since 2008-2009). I’ve never had this kind of problem (or at least nothing which couldn’t been solved). I’m sure it has something to do with this specific network.

After many tests and changes, the conclusion is that COMODO has became a total ■■■■. It doesn’t address properly 127.X.X.X (even when it is disabled). It is time to change it with something better.

Try :
ipconfig /flushdns
ipconfig /registerdns

Please provide output from following commands:
ping -4 localhost