Thunderbird (launched by Mailwasher) can't connect (bad PATH in CFv3 rules)

No problems yesterday when I installed v3. Thunderbird was detected, I authorized it as a “Trusted app,” and it was a smooth sail from there. Today, however, was a different matter.

I normally fire up Mailwasher (an old version) before opening Thunderbird, to filter messages before downloading them. Mailwasher did its thing after I marked it as “Trusted” in the popup, and the filtering app then automatically fired up Thunderbird as usual.

CFv3 showed a popup then, which at first didn’t surprise me since V2 also did that since Mailwasher was a “parent” app in this case. I frowned a bit since I read somewhere in the forum that v3 works now differently, but I brushed it aside and went with the flow.

However, this time TB couldn’t connect, even when I clicked on “Trusted App.”

No matter how many times I tried to check e-mail with TB (or those times TB checked for e-mail automatically), CFv3 kept asking me if I wanted to let TB to connect… I kept defining it each instance as a Trusted App, but CFv3 would not allow it to go through.

When I checked the “Network Security Policy,” I noticed that TB was “defined” multiple times, something that didn’t happen yesterday no matter how many times I checked mail. Each of the lsited instances was defined as “Trusted.” HOWEVER, I did notice that the PATH to Thunderbird was defined differently than yesterday.

This is how it was defined yesterday (what I would expect from a modern app that understands how Windows XP handles directories):

C:\Program Files\Mozilla Thunderbird\thunderbird.exe

And this is the Path that CFv3 is using today (what I would expect from OLDER apps that cannot handle spaces in directory names in WinXP):

C:\PROGRA~1\Mozilla Thunderbird\thunderbird.exe

I’m no programmer (and my apologies if my “insight” is a stupid one), but I have the nagging feeling that the path used has something to do with this. It’s as if CFv3 all of a sudden could not deal with WindowsXP’s directory names., and every time it gets a request from what it interprets as C:\PROGRA~1\Mozilla Thunderbird\thunderbird.exe, it assumes it is a “different” app… since the path is truncated.

Is there any validity to what I’m thinking?


OK, I deleted in “Network Security Policy” all the TB definitions with truncated Paths, as well as Mailwasher’s definition just in case, and rebooted. Firing up Thunderbird first, instead of Mailwasher, and CFv3 allowed it to connect.

I am assuming then that using Mailwasher ver 4, which in turn opened automatically Thunderbird once it filtered mail, was somehow connected to this (maybe it was Mailwasher who gave out that bad path to CFv3… I’m just guessing here). I’ll keep checking…

Update: I configured Mailwasher 4 NOT to open TB after it has filtered e-mail, and now take the extra step of opening TB by hand, and the issue is gone. I am then going to assume that Mailwasher 4 did “pass along” to CFv3 the truncated path, causing the firewall not to “find” TB properly.

My only concern is, if it happened with Mailwasher 4 it could possibly happen with any older app that opens TB (or maybe any other web-connecting app) as a “parent” app. I’m going to download the trial of Mailwasher 6 to see if that helps.

Update 2: When using the trial of Mailwasher 6 the problem does not reappear. sigh Oh well, I’ll just keep on using version 4 and then open TB manually, no big deal. I’ll buy ver.6 once I can afford it. :stuck_out_tongue:

If anyone can throw his/her 2 or 3 cents in this, I’d appreciate it. I’m here to learn. :slight_smile:

Hi there,

I too had a problem with Thunderbird after upgrading to Comodo v3…I couldn’t send emails, no matter how I configured the firewall…only when I disabled it could I send mail.

I was happy with v2 but have a bad feeling about this new version…I might go back to Zonealarm!

Ack, sorry to hear that.

The few “problems” that I’ve experience have been, thankfully, minor. The one I posted above at first looked like a major one of me (since I check my e-mail frequently), and I started running around my room pulling my hair and going “Oh Noes!!11!!! I haf to go bak to ver2!!1!.” When I calmed down and noticed the weird Paths, I decided that the problem lied mostly with the old Mailwasher app than CF. Admittedly, this didn’t happen ever with v2. However, from what I can gather in the forum, the changes from v2 to v3 have been so drastic that it’s almost a different piece of software (especially with the addition of D+)… so v3 is somehow dealing with Mailwasher differently.

I have to be fair here. Although I have to re-learn how to use CF, v3 has basically worked fine “out of the box” for me, with far FAR less pop-ups than v2 and it feels gasp lighter. I DID made sure to uninstall the previous version first, though, as well as hunting down and deleting Outpost Firewall’s registry entry, since CFv3 would not install thinking it was still installed. I really hate it when programs do not clean up thoroughly after them when you uninstall them.

V3 will obviously have some teething pains, though I can only hope they will go away as they keep refining the software. :slight_smile:

Just an update: it looks like even using the recent Mailwasher 6 doesn’t solve the problem mentioned above after all. Once more, if I allow Mailwasher to launch my e-mail program (Thunderbird in this case), CF3 won’t recognize it from that point forward, no matter how many times I mark TB as “Trusted.” Even if I close TB and open it manually, CF3 will not recognize it.

I have to remove all those endless TB entries (cataloged again within “Network Security Policy” as C:\PROGRA~1\Mozilla Thunderbird\thunderbird.exe), and restart my machine so that CF3 can recognize TB once more.

This, together with “The Defense+ is not functioning properly” warning that never goes away (and that seems to keep Defense+ inactive) is tempting me to go back to CF2.

I’ll hang onto CF3 for as long as I can and keep an eye on the forums. This is obviously not something that will be solved overnight, and I trust the devs at Comodo will fix CF3 in the fullness of time.


Are you using gmail or encrypted email through your ISP? Comodo left port 995 off the port list that supports their email client rules, so won’t work if you try to use that predefined policy. If you are using gmail and Thunderbird, also need to add port 587. Go to Firewall/Common Tasks/My Port Sets and add 995 and 587 to the POP3/SMTP ports and see if that helps. Should be in next fix, per Melih. Don’t know why you got all the repeats; hasn’t happened to me (yet?). Good luck; Ed. :wink:

Thanks for your comment sded, I appreciate it.

Actually, I never had any problem at all using Thunderbird with CF3 “out of the box.” And I am using TB to download e-mail not just from the account at my ISP, but from Gmail, Hotmail, and Yahoo Mail.

The glitch detailed here happened after MailWasher launched TB automatically (I had it set up that way: it opens TB after filtering SPAM directly in the mailserver). The instance of TB launched by MW was not recognized by CF3, and neither could CF3 recognize any future instance (or connection attempts) of TB. Only a restart (after removing the bad TB rules within CF3) fixes that.

I believe that all those repeats happened since CF3 got confused with the path it acquired (C:\PROGRA~1\Mozilla Thunderbird\thunderbird.exe), and thinks every attempt is done by a different app. No way it’s going to find the program (or relate it to the original application rule) with a truncated path like that.

The original rule, which I created by opening TB normally, has a proper path: C:\Program Files\Mozilla Thunderbird\thunderbird.exe. Maybe I should upload a screenshot here to show what I mean.

All in all, I “solved” this by not having MW launching TB. I do that by hand now after MW deals with SPAM. This wasn’t an issue with CF2.4 though. All in all, this will probably only happen to you if you were to use Mailwasher (I think)…

I’m not sure how the port issue you mention would related to this weird glitch, but I will attempt that solution to see if it helps with the Mailwasher thing. :slight_smile:


It also might help if you go to Defense+ and make Mailwasher a trusted application, one that is allowed to launch other programs (among other things). I ran into a few programs that should have prompted me and didn’t, but worked OK when I did this by hand. If you didn’t use the predefined firewall policy for email client, but just clicked “allow”, you shouldn’t have had any problems with the missing ports.

OK then, I’ll leave the ports as they are then for the time being, since it seems to work as it is.

I just checked and, aye, Mailwasher is already listed as “Trusted” within the rules (just as TB is). All I can say that it’s a weird glitch… but probably a minor one won’t affect most users (I mean, it looks like I’m the only one reporting something like this :-\ ). Maybe it’s just Mailwasher’s fault… I’ll check their forums to see if I can dig anything.

I think I may have found a workaround to my problem. I don’t know how reliable this is, but will post it in case a Mailwasher user visits this forum with the same questions.

While browsing MailWasher’s forums, I read something I already knew but had forgotten: than one could specify the path of the mail app within the program, instead of letting it get the address of the default mailing app automatically from Windows. So I did that within MailWasher Tools>General Options, specifying the proper path: C:\Program Files\Mozilla Thunderbird\thunderbird.exe.

Tested it a few times, letting it launch TB, and every time CF3 recognized the app. I won’t do a Victory Dance yet… if it keeps working great after a week, then I will. :slight_smile:


I’ve just learned from another post that what I described above is a “short path problem” that the devs know about… and not a bad or truncated path as I believed.

From what I Goggled, it seems that shortpaths to make Win XP (which uses long file paths) backwards compatible with Jurassic age Windows and DOS. :stuck_out_tongue:

Well, at least it’s great to know they’re working on it :BNC