thunderbird in defense+ events

I just got comodo installed to use as firewall protection along with my NOD32, after having nothing but problems with ESET’s stupid firewall in their Smart Security package. I’ve got things pretty much how i want it except one thing. My thunderbird keeps appearing in the Defense+ Events screen with the flags “DNS/RPC Client Acess” every few minutes and every once in a while “Direct Keyboard Access”.

I’ve specified thunderbird as a trusted application in both the firewall and defense+ settings. How do i make it stop blocking whatever it is TB is trying to do?

[attachment deleted by admin]

Try moving it above the All Applications rule in Defense + → Advanced → Computer Security.

Does that help?

Actually, i just went to try and i noticed that, even though i had thunderbird opened and checking for messages ever 5 mins all night, there were no events for it in defense+. Maybe it just took a while or a reboot or two for the changes to take effect? I’m not sure, but if i see it again i’ll give this a go. Thanks