Thunderbird Email Client Problems

I’ve tried the email client workaround, and Thunderbird still cannot send or receive email in 3.0, while it works fine in 2.4. Are there any other solutions, or do I need to simply reinstall 2.4?

Personal Message (Offline)

ATTN : CFP 3.0 Temporary Fixes
« on: Today at 01:29:54 AM »

From egemen:

Hi Guys,

More than a million PCs is using CFP 3right now and the weird bugs/problems are posted in the help board.

2 of these problems seem to be recurring. Here are the temporary fixes until we update the executables:

1 - cmdagent.exe 100% CPU consumption:

This has been verified and fixed with the upcoming update. It is related to patched uxtheme.dll.
However, until the updates are issued the temporary fix is disabling the registry protection :

  • Defense±>Advanced->Defense+ Settings->Monitor Settings
  • Uncheck “Protected Registry Keys”
  • Press Apply and restart

2 - System Slowdown issue :
It is related to the load on comodo lookup servers.

Online file lookup must be disabled

  • Miscellaneous->Settings->Update
  • Uncheck “Automatically perform an online lookup for the unrecognized files” option
  • Press Apply button

Both 1 & 2 should solve the most of the problems.

3 - Email client problems

  • Firewall->Tasks->Stealth Ports Wizard
  • Select “Alert me to incoming connections”

Then Protocol analysis should be disabled.

  • Firewall->Advanced->Attack Detection Settings->Miscellanous
  • Uncheck “Do protocol analysis” option

Thank you all for the cooperation,


Have you tried to delete the entry for Thunderbird in Firewall>Advanced>Network Security Policy>Application Rules and in Defense+>Advanced>Computer Security Policy to force CFP3 to find it again when you run it? Not sure if this will help just something else to try if you haven’t already.


Thanks for the response.
CFP3 found Thunderbird the first time, but I tried your suggestion. It finds Thunderbird again after I follow your suggestion, but I still have no Thunderbird email connectivity.

I’m having the same problem with both Thunderbird and Eudora. The workaround doesn’t fix the problem for me either.

Both worked fine under 2.4.

Only fix I’ve found is to turn off Comodo while I gather email.

Any other suggestions will be appreciated.

Are you using gmail or encrypted email through your ISP? Comodo left port 995 off the port list that supports their email client rules, so won’t work if you try to use that predefined policy. If you are using gmail and Thunderbird, also need to add port 587. FTP also usually won’t work if you use their predefined policy.

you can modify the predefined policy to include these ports to see if it works for you.


Melih, perhaps add the other email ports in the next upgrade? Not everyone spends their time playing with ports vs protocols for email. :slight_smile: Need to add 995, used by most pop3 encrypted email; 587, used by gmail for smtp encrypted using TLS (Thunderbird; 465 is used for SSL/Outlook Express), 993 for encrypted IMAP. I use them all, so added them to the port list and all was well. The FTP client ruleset supplied is for active FTP;virtually all users and clients have gone to passive FTP. Adding rule to allow TCP out everywhere completes the policy. Great product. Now if I could export my settings and get the log to stop taking 0000Z to 0000PST as a holiday, and a few other minor things… (:CLP), Vista Ultimate, Avast!

Thanks for that Sded, passed it to our dev guys…

OK, I found my problem. YMMV.

I checked the “Firewall Events” and found a bunch of entries for AshMailSv.exe being blocked.

Turned out I had apparently told Comodo to use some preset value for my virus checker (avast!) that it didn’t like relating to AshMailSv.exe. I deleted the value in the “Network Security Policy” and then told Comodo during mail checking to always allow the connection as a custom setting.

Now it works.

My Thunderbird e-Mail client (pop3, RSS, etc) works perfectly well with the default CFP settings. I think more analysis needs to be done before we go rushing off changing the defaults. My 2 cents.


If you don’t encrypt your email or use gmail configured for pop3 access you will never see these changes-you just can’t do encrypted email until you update the ports. I use them exlusively, because I often use wifi to connect to public and private unsecured internet access points. If I didn’t do that, I would be happy with a NAT router and the Windows firewall. Nothing will change in your system, since you don’t try to access the added ports. As far at the FTP defaults, see for more than you ever wanted to know about ftp, and why mostly passive is used. And why the current defaults usually won’t work. :slight_smile:

Okay, looks like some analysis has been done on this. Then by all means, enhance the default rules for passive FTP, encrypted e-mail etc… One needs to be very careful when making rule changes and my previous post was an appeal for using caution when making changes in this area. For example, a rule change in RC1 allowed a DIRECTX keylogger test to do its thing without having CFP block it.