thunderbird - connection refused


i have 3 accounts set up in my mozilla thunderbird client, and for a few days i’ve had a problem with checking my e-mail on two of them. before that everything was working fine. i get a message:
cannot connect to server pop3.something.something - the connection was refused.
i’ve read some other forums and in similar cases people suggested that it’s a firewall problem.
so i checked by disabling comodo firewall and it was working perfectly again.
thunderbird has all the permissions set for allow in comodo - in the firewall section it is set as an e-mail client, and it it set as a trusted application in defense+
i noticed that these two accounts connect to pop3 on port 110, while the third account that is working fine (gmail) connects on port 995.
so i tried to add a firewall rule to thunderbird so it could accept connections on port 110, but unsuccesfully (maybe i’m doing it wrong…)
i don’t know what else to do, please help!


It may also be a service problem. I’m having trouble with Yahoo–more like Yahoo’s been having service problems intermittently for quite a long time now.

i don’t think it’s a problem with the service, cause each of these 2 accounts is from a different service, and besides, everything works just fine if i disable the comodo firewall.

any other suggestions?

Can you show us your application rules for T-bird?


Apparently the rule for using port 995 for gmail did not end up in the T-bird rule

Add the following rule:
Action: allow
Protocol: tcp
Direction: out
Description: rule for gmail

Source address: Any
Destination address: Any
Source port: Any
Destination Port: 995

When done make sure the rule is above the yellow Ask rule.

but gmail connects just fine, it’s those other 2 accounts that don’t - they use port 110.
so i added a rule with port 110 instead of 995 for them and it didn’t help.
it’s all very strange, cause both ports are listed under pop3/smtp in “my port sets” in comodo, and it looks like this:

ok, i solved it :slight_smile:
i don’t know how it happened, but in the account settings i had the safe connection ssl turned off.
i ticked it, and the port used by pop3 changed from 110 to 995, like the gmail one, and both accounts started connecting!

Eric, thanks so much for your time and help :slight_smile:

Glad you finally found it. I have had similar things happened where a setting in a place you weren’t expecting turned out to be the problem.