There's something wrong with the flash component

The lyrics are not properly displayed, don’t know why this is happening. Can anyone help? Thx

Website: http://www.xiami.com/

OS: Win8 Enterprise Chs
Dragon: 25.2
Flash:11.6.602.180

[attachment deleted by admin]

Looks like flash is still broken. Out of interest, which version of flash are you using?

Re: Comodo Dragon ver 25.1 is now available for download

It still does it in 25.2 and the latest Flash plugin.

Is there a way to hook pepper flash in to dragon, without having to install Chrome on the same system?

I saw something somewhere that said it is possible to do but it was complicated and you have to do it all over again every time the Flash in Chrome gets updated.

You’ll still need a coppy of pepperflash, however: Here

I tried that :wink:

But on the VM I used to install Chrome in it works, if I copy just the PepperFlash folder to my host and try the same it fails.
I have disabled the normal flash plugin in dragon, it seems it needs more than just the copy of the dll.

I’ve extracted Pepperflash folder from latest Chrome installer and put it on C.
Then I’ve modified CD shortcut with this

"C:\Program Files\Comodo\Dragon\dragon.exe" --ppapi-flash-path=C:\PepperFlash\pepflashplayer.dll --ppapi-flash-version=11.6.602.180

Everything looks OK here.
I know that I must replace Pepperflash with new versions and change the shortcut but is not a big deal for me.

[attachment deleted by admin]

Can you try this link?
http://www.adobe.com/software/flash/about/

It fails on my setup.

Looks OK?

[attachment deleted by admin]

Hi Ronny,
That site works here with pepperflash.

Is already disabled…

Sorry Ronny, I just tried it but I was to slow at editing my post.
My apologies.


Edit: [url=http://helpx.adobe.com/flash-player/kb/find-version-flash-player.html]Flash player version check[/url] First screenshot is the standard Adobe Flash Plug-in. Second screenshot is with Pepper Flash Plug-in.

[attachment deleted by admin]

Are you running Dragon portable or full install?
Based on the path I assume full install, In my system it doesn’t show the pepflash process loaded in memory-redirect or with process explorer it didn’t load the .dll

Fixed it, I initially placed it in \Program Files (x86) and put " around the path, seems that is not allowed.
Put pepperflash folder in space less path fixed the issue

Good to see you have it working.
I have tried it with both portable and installed versions with success.

I used the following path for my portable, this will vary depending on location.
In my case I used the same location for pepper flash in both my portable and installed versions.

C:\Users\username\Downloads\Comodo\Dragon\dragon.exe --ppapi-flash-path=C:\PepperFlash\pepflashplayer.dll --ppapi-flash-version=11.6.602.180

strange, now it’s failing again, didn’t change anything…

Is it still present in dragon://plugins/?

Okay found the cause, it’s a know issue between EMET 3.5TP having enabled SEHOP on dragon/chrome.exe with Chromium plugins.
https://groups.google.com/a/chromium.org/forum/?fromgroups=#!msg/chromium-bugs/SMw1mo5YCBg/vcHPr7-ziFcJ

You have to disable SEHOP on dragon to get it working :cry:

Thanks for posting back your findings Ronny, even though the reason is a little unfortunate. :slight_smile: