There is a Long time lag after connecting before being able to use internet

I am not sure if this is a comodo issue, a Windows XP sp3 issue or an issue with my computer settings but I just discovered it happens with both my wireless connection to my router connected to DSL AND while using dialup.

Here is what happens. My wireless connection will connect and indicate connected at 54mbps with excellent signal strength and other computers (≤2) will be happily using the same router/dsl connection. There will be a 30 second to 2 minute lag time before I can actually load a webpage or get any throughput. AKA very long latency periods. This seems to have been occuring for a while now (possibly seeming to coincide when I first used Comodo or updated to XP SP3) but I overlooked it as a quirk of my aging router or problematic dsl connection…until now. I have been messing about with dialup and trying to get my phone lines as clear as possible. I noticed the same problem under dialup where it will connect but take about a minute before I can get bytes to start swapping. Back in the day, when I used to use dialup I could load webpages immediately after connecting. So what’s going on? Is there something I haven’t configured correctly?

Is there any difference when firewall is disabled? If yes, have you changed any thing under attack detection settings (CIS-Firewall-Advanced-Attack Detection Settings-Miscellaneous) especially checksum verification?

What other security softwares do you use? Is there two firewalls or two antiviruses etc?

Still happens when firewall is disabled. It happens on 2 different dialup isps and it takes at least 40 seconds to allow browsing. Takes even longer on the wireless. In the status bar of the browser it will indicate looking up… and nothing happens. What’s going on?

Under attack detection settings>Miscellaneous I have both block fragmented IP datagrams and protocal analysis checked off. Nothing else. I haven’t changed anything to my recollection.
No other firewalls or antivirus except the Trend Housecall plugin. I have hijack this, adaware and spybot with none of the real time addons running which I disabled deliberately.

Given the message that you’re seeing in the browser (Looking up, this looks like it could be a DNS issue (which is what it’s basically doing with the “Looking up” message). Are you using Comodo’s secure DNS or some other?

In any event, you can test what the DNS is doing (or not) by running a program called nslookup.exe (usually found under \WINDOWS\system32). Nslookup = Named Server Lookup.

Reference material: DNS Lookup []

Which browser are you using?. I have always found that IE loads quicker than Firefox even when Firefox is nominated as the default browser. Even now with 10MB broadband IE loads practically instantaneous while Firefox the first time I log in on a session will take perhaps 2-3 secs but after that initial time will load immediately. I am using the Comodo DNS servers but previously used Open DNS without any difference. When I just had a telephone connection it could be very slow depending on traffic.

Not using comodo’s secure dns to my knowledge. I ran nslookup and got the following response in a command prompt.
*** Can’t find server name for address 192.168.XX.XXX (my router’s address): Non-existent domain
***Default servers are not available.
Default Server: Unknown
Address: 192.168.XX.XXX

That looks like something. Has to do with my router settings?

Long lag before initial load happens on both firefox and IE and other net aps. about 40+ seconds.

Is your network card set to automatically acquire DNS server addresses? That is the default setting from Windows with which your computer will get the DNS server addresses from the “Default gateway”; your modem/router.

Yeah all connections wireless, LAN and dialups are set to obtain DNS server address automatically and IPs under TCP/IP.

NSLookUp (unlike browsers) is not very tolerant. It tries the primary DNS and if that doesn’t work, it tries the secondary DNS and then gives up. Whereas your browser is likely to hammer away (alternatively trying the primary and secondary DNS) for sometime before giving up. Thus the apparent delays.

However, it seems that NSLookUp didn’t even try the secondary DNS server. As it couldn’t find your router at all, this implies that there was a temporary connection problem. So, it’s either an intermittent connection problem with the router itself, the wireless connection or perhaps the ISP.

The wireless, being subject to external interference (no, I don’t mean hacking) and such, is an obvious suspect. You should check the WLAN signal strength and, if you can, revert to a LAN cable connection for testing.

Ok I directly connected to my router with the LAN cable. Firewall disabled. XP Antispy most options disabled. Still got a lag about 32 seconds, before browser was able to load webpages. This is referred to as latency right?

Ran nslookup.exe again and got same message.

Checking my router’s settings. Connection is set to “continuous”. Under LAN 802.1d Spanning Tree is disabled. Should that be enabled? DHCP Server is enabled. Qos, Nat and firewall are all enabled. UPnP is disabled under NAT. Should that be enabled? Nothing else is altered from default ie. no port forwarding or dmz. Only have MAC addresses set in access control under wireless but it lagged with LAN and dialup too.

Logged straight into modem after resetting it. Changed ‘connect on demand’ to ‘Always try to connect.’ Other option was ‘Smart Keep Alive’. Still got the lag. I’m thinking it has to do with my laptop’s settings.