There IS a issue with Ad-Aware AE and CIS 3.8.64739.471_XP_Vista_x64[SOLVED]

I know there is a growing post about a problem with CIS and Vista64 where apps are blocked with no pop ups or anything and many users were posting about their security apps they have and with the data gathered it looks like the culprit might be Ad-Adware AE.

I would like to add that I just removed it and tried CIS 3.8.64739.471_XP_Vista_x64 once again and the problem went away. I have CIS running now and getting pop ups to allow/disallow etc when needed and not everything is blocked as before.

I know I could of posted this in the other topic and not posted here also but figured this will get seen better with a topic of its own. Thanks!

This info is very helpful…thanks! I will try uninstalling Ad Aware. Which version of Ad Aware did you have? I have the Anniversary Edition. Did you reinstall Ad Aware after CIS was installed?

It was the AE version and I did not re-install it afterward.

Can you please post the AdAware version numbers used ?

Mine was version 8

Dev’s have identified the issue, this should be fixed in the next release.
Please keep an eye on the forum this/next week…

In between you could disable D+ permanently to “workaround” this issue.

Ronny… thank you for acknowledging the issue properly (not ‘blaming’ Ad-aware)… and for posting a genuine ‘Comodo’ work-around (rather than again dumping on Ad-aware by saying to uninstall it). (:CLP) This is the professional response to an update-generated glitch. I, for one, appreciate that. :Beer Now I can look forward to getting my Comodo users updated… eventually ;)) :BNC

Note: Unfortunately… from reports, it seems that update .477 does -not- fix the x64 glitch… so hopefully another update is forthcoming.

Yes I have also uninstalled Ad-Aware version 2008 and then installed Comodo version CIS_Setup_3.8.65951.477_XP_Vista_x64, and then re-installed Ad-Aware Anniversary Edition free version from:

I have just recently installed the Comodo Firewall V3.11.108364.552 and find that an incompatibility also exists in Vista Home Premium x32 between the Comodo Internet Firewall application and Ad-Aware AE V8.0.7.
An Ad-Aware Smartscan will hang after about 14 secs. if the Comodo Firewall is active, although it’s icon in the system tray remains animated.
At this point Ad-Aware can only be removed through the Task Manager. There is no problem if the Firewall is closed prior to scanning. No problems exist with either Spybot or Spyware Blaster.
I understood that this problem was to have been fixed some time ago or is the only solution a reinstall of both applications, if so, in what order?

Hello cenwag,

Could it be that you have blocked Ad-Aware network access ?
Can you check the Firewall Policy and see if there is any Ad-Aware there ?

I have no problem connecting with the Lavasoft server to download the regular Ad-Aware updates.
The problem is that the Ad-Aware scan will hang if Comodo is active. Ad-Aware is shown as a trusted application in Comodo. The Windows Firewall is off. Where can I find the Policy you mention?

For the firewall part open the GUI, Firewall, Advanced, “Network security policy”.
For defense+ GUI, Defense+, Advanced, “Computer Security policy”.

Maybe you can remove all ad-aware entries from the computer policy, or change them to “trusted application” so they don’t get blocked by Defense+

If not try this on Defense+ settings, Deactivate D+ Permanently.
And reboot see it that helps, it did on the previous bug.

:-TU Eureka!! Instead of just having the main Ad-Aware executable (Ad-Aware.exe)as a “Trusted Application”, I also made the other 3 executables (AAWTRAY.exe, AAWWSC.exe and AAWService.exe) “Trusted Applications” which resolved my particular problem and the scan now runs to completion.
Thank you for your time and efforts, maybe this will be of some help to others experiencing similar problems.

Good to hear :-TU