The wildcard pattern "?" doesn't match if "." inserted in file name [M1236]

A. THE BUG/ISSUE (Varies from issue to issue)
Can U reproduce the problem & if so how reliably?:
Yes, every time.
If U can, exact steps to reproduce. If not, exactly what U did & what happened:
1: Open HIPS > Protected Objects > Blocked Files
2: Add any file to “Blocked Files”
3: Click “Edit” and set the pattern “C:\test???.txt”
5: Apply the settings
6: Try to create two files: “C:\test\abc.txt” and “C:\test\a.c.txt”
One or two sentences explaining what actually happened:
The first file will be blocked, but the second won’t
One or two sentences explaining what you expected to happen:
Any TXT file in the folder “C:\test” with the name in 3 characters must be blocked.
If a software compatibility problem have you tried the advice to make programs work with CIS?:
NA
Any software except CIS/OS involved? If so - name, & exact version:
NA
Any other information, eg your guess at the cause, how U tried to fix it etc:
This problem occurred when I was trying to block scripts with the path longer than 129. I have used that pattern:
*???.vbs
But it doesn’t work when the name of script or its folder contains “.”

B. YOUR SETUP
Exact CIS version & configuration:
CIS 7.0.317799.4142
Configuration: Proactice Security
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:

Antivirus:
Stateful
“Do not show alerts: Block threats”

HIPS:
Safe Mode
“Don not show popup alerts”: disabled
“enchanced protection mode”: disabled
the rule for explorer.exe: allowed application

Auto-Sandbox: disabled
“heuristic command-line analysis”: enabled
Viruscope: disabled

Firewall:
Safe mode
Website filtering: enabled

Have U made any other changes to the default config? (egs here.):
AV: “Do not show alerts: Block threats”
HIPS - “enchanced protection mode”: disabled
HIPS > Protected Objects > Blocked Files: C:\test???.txt
Auto-Sandbox: disabled
Viruscope: disabled
Have U updated (without uninstall) from CIS 5 or CIS6?:
No
Have U imported a config from a previous version of CIS:
No
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
WinXPx86-SP3 (VMware)
The same problem occurs on Win7x86-SP1 (real), UAC is enabled
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=None b=None

[attachment deleted by admin]

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

Hi kibinimatik,

Devs have marked this issue as “Fixed” in version <8.0.0.4314>. Please verify.

Thanks.

Hi qmarius,

it is not fixed, which is verified on my video

Thanks.

[attachment deleted by admin]

Thank you for checking this. I have updated this post.

The devs have not marked this as Fixed in the tracker. However, sometimes bugs are fixed by the release of new versions, but not marked as Fixed in the tracker.

If you are able please check with the newest version (CIS version 8.0.0.4337) and let me know if this is fixed on your computer with that version.

Thank you.

This is not fixed with the version 8.0.0.4337.

Thank you for checking this. I have updated the tracker.

Hello,

The devs have not marked this as Fixed in the tracker. However, sometimes bugs are fixed by the release of new versions, but not marked as Fixed in the tracker.

If you are able please check with the newest version (CIS version 8.1.0.4426) and let me know if this is fixed on your computer with that version.

Thank you.

Hello

This is not fixed.

CIS 8.1.0.4426
Configuration: Proactive Security
Win7x64SP1 (VMware), Admin, UAC is enabled

[attachment deleted by admin]

Thanks i have updated the tracker.

According to Windows wildcards syntax, ? does not match dot. Moving to resolved.